CyberHosting

Rainloop No Longer Working (SELinux Disabled)

edited December 2018 in Bug Report
Provider: Contabo

System: 7.6.1810

Installation option: since during the installation.
there will be few option to choose,so please provide it as well.

OLS or Enterprise?
OLS

Installing from official server or mirror server?
Official


Replace JS/CSS files to JS Delivr?
No

Install Memcached extension for PHP?
Yes

Install LiteSpeed Memcached?
Yes

Install Memcached?
Yes

Install Redis extension for PHP?
Yes

Install Redis?
Yes


Problem:

When I try to access the built-in Rainloop in the web panel, I can longer can reach it. It loops endlessly and times out regardless of the browser. I tried both via both my proxied link (e.g. panel.mydomain.com/rainloop/index.php) and the ported connection (mydomain.com:8090/rainloop/index.php) and neither work now. I could just build a separate webmail install entirely but it is worrisome that the mail client is no longer operative.

Comments

  • edited December 2018
    What do you see in web server error logs when you visit RainLoop?

    https://cyberpanel.net/docs/log-files-on-cyberpanel/

    Update: I can see your ticket, that your issue is resolved.
  • What do you see in web server error logs when you visit RainLoop?



    https://cyberpanel.net/docs/log-files-on-cyberpanel/



    Update: I can see your ticket, that your issue is resolved.

    Actually, I just found the problem and it isn't resolved. The problem is Docker. If I install Docker and enable it, it causes PHPMyAdmin and Rainloop to become completely inoperative. If I simply stop the Docker process, though, they become accessible. Weird. I need Docker for Discourse, so your help is needed.
  • edited December 2018
    That is, I run "systemctl stop docker" and then I can access PHPMyAdmin and Rainloop. But if I run "systemctl start docker", which I need for Discourse, PHPMyAdmin and Rainloop no longer are reachable. With Docker enabled, though, all my sites and every other feature in CyberPanel continue to work, though. Peculiar behavior. I wonder what the fix or workaround is.
  • If docker runs, maybe there is not enough ram for lsphp processes?
  • That was actually my last guess. I currently am running with 8GB of RAM and only 8% of it in usage. Let me add that I have not yet installed Discourse so though Docker is installed and enabled, no Docker containers have been created. That is the peculiar thing about this all.
  • So, If I want to reproduce on my end. I only need to install and enable docker?
  • As an intermediate fix, I installed Roundcube under my mail. subdomain site and that works flawlessly. There must be unique PHP settings specific to Rainloop and PHPMyAdmin which happen to be separate from actively published web content under website's public_html like my Roundcube install.
  • We are still investigating, it is something wrong with LSCPD that powers CyberPanel.
  • Cool! I appreciate all the help.
  • Can you submit a ticket with login details of any server having this issue?
  • It looks like there is something wrong with lsphp7 binary I've replaced it with lsphp5 binary available at http://www.litespeedtech.com/packages/lsphp5_bin/x86_64/lsphp5 and RainLoop seems to be working.

    PHPMyAdmin does not seems to work as this is very old PHP
    Fatal error: Call to undefined function Symfony\Polyfill\Mbstring\iconv_strpos() in /usr/local/lscp/cyberpanel/phpmyadmin/vendor/symfony/polyfill-mbstring/Mbstring.php on line 490
    We will fix the error in lsphp binary.
  • having this same issue keep getting "Unknown error" when trying to login, just upgraded from 1.7.4 to 1.7.6
  • cole said:

    having this same issue keep getting "Unknown error" when trying to login, just upgraded from 1.7.4 to 1.7.6

    Are you using docker as well?
  • Not to my knowledge, i just updated CP and came upon this issue
  • this is the log
    Jan 7 15:30:03 trg postfix/smtpd[5298]: warning: hostname 177-92-185-104.xmaxtelecom.com.br does not resolve to address 177.92.185.104: Name or service not known
    Jan 7 15:30:03 trg postfix/smtpd[5298]: connect from unknown[177.92.185.104]
    Jan 7 15:30:03 trg dovecot: auth: Error: dlopen(/usr/lib64/dovecot/auth/libdriver_mysql.so) failed: /usr/lib64/dovecot/auth/libdriver_mysql.so: undefined symbol: net_str2port
    Jan 7 15:30:03 trg dovecot: auth: Fatal: Unknown database driver 'mysql'
    Jan 7 15:30:03 trg dovecot: master: Error: service(auth): command startup failed, throttling for 60 secs
    Jan 7 15:30:03 trg postfix/smtpd[5298]: fatal: no SASL authentication mechanisms
    Jan 7 15:30:04 trg postfix/master[1125]: warning: process /usr/libexec/postfix/smtpd pid 5298 exit status 1
    Jan 7 15:30:04 trg postfix/master[1125]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Jan 7 15:30:14 trg dovecot: imap-login: Warning: Auth process not responding, delayed sending initial response (greeting): user=<>, rip=::1, lip=::1, secured, session=
    Jan 7 15:30:34 trg dovecot: imap-login: Error: Timeout waiting for handshake from auth server. my pid=5303, input bytes=0
    Jan 7 15:30:34 trg dovecot: imap-login: Disconnected: Auth process broken (disconnected before auth was ready, waited 30 secs): user=<>, rip=::1, lip=::1, secured, session=

    im not sure where .xmaxtelecom.com.br is coming from that's not my domain
  • Create a separate thread, this thread is related to the docker issue.

    I can see your log says
    Jan 7 15:30:03 trg dovecot: auth: Fatal: Unknown database driver 'mysql'
    It looks like dovecot has some problem, but please use separate thread or ticket.
  • It looks like there is something wrong with lsphp7 binary I've replaced it with lsphp5 binary available at http://www.litespeedtech.com/packages/lsphp5_bin/x86_64/lsphp5 and RainLoop seems to be working.

    PHPMyAdmin does not seems to work as this is very old PHP

    Fatal error: Call to undefined function Symfony\Polyfill\Mbstring\iconv_strpos() in /usr/local/lscp/cyberpanel/phpmyadmin/vendor/symfony/polyfill-mbstring/Mbstring.php on line 490
    We will fix the error in lsphp binary.
    Any update on this fix? Thanks!
  • Ended up having the same issue rainloop and phpmyadmin only connect when docker is paused
  • This issue is now resolved, new LSCPD binary will be packaged with next CyberPanel version.
  • Can confirm the same issue. Thanks for the fix!
Sign In or Register to comment.
CyberHosting CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!