503 Service Unavailable — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

503 Service Unavailable

edited February 2019 in Bug Report

I just did this (https://blog.cyberpanel.net/2018/12/25/how-to-remove-port-8090-from-cyberpanel/) a few hours ago and right now my website is saying this

Service Unavailable
The server is temporarily busy, try again later!

I have been trying to install a software and after the installation I get the same error?

any idea? Thanks


  • Port 8090 is giving you 503 error?

    You can try systemctl start gunicorn.socket
  • No, I can log in using IP:8090 but the new website to use the panel without the port and another website is giving me that error 503

    Used that command and it still doesnt work.
  • 503 error means you did not setup proxy app correctly. What is output of

    cat /usr/local/lsws/log/error.log | grep ERROR
  • [[email protected] ~]# cat /usr/local/lsws/logs/error.log | grep ERROR
    2019-02-11 00:03:19.967116 [ERROR] [config:server:vhosts:vhost:Example:context:/protected/] Path for context location is invalid: /usr/local/lsws/Example/html/protected/

    but its not just the web panel its another website too that is not running in a port.
  • is there a way to install the 1.7 version? bc the another website was working before the update

    *Just wanna test
  • I am not sure what you are trying to say. Your website should run without specifying any port as browser default is 80 and 443.

    In recent updates OpenLiteSpeed is not upgraded, so you use the same OpenLiteSpeed even after the upgrade. So it does not matter if you have version 1.7 of CyberPanel.

    However, if you want you can upgrade OpenLiteSpeed
    yum update
    yum upgrade openlitespeed
    Still not sure if you have a problem with CyberPanel or the websites being run, please explain the steps to reproduce the issue.
  • https://blog.cyberpanel.net/2018/12/25/how-to-remove-port-8090-from-cyberpanel/

    I followed this guide and it worked for a few hours I could access to the panel without the port but after that the website just gives me 503 error...

    If I remove the Rewriterule the website works as default website but if I add the rewrite rule again it keeps giving me the 503 error...

    I also get 503 error in another website, happened the same the website worked a few hours and after that just 503 is shown.
  • is there a way to check each website logs? to get the cause of the error?

    (the website home logs just show this)

    [12/Feb/2019:02:48:35 -0500] "GET / HTTP/1.1" 503 665"
  • We can talk about your other website first. Please do not mix 2 issues. Do you have enough resources available on your server?

    And your rewrite rules on the other site does not have anything to do with 503 error on other sites.

    You can also turn on php error logs. Also, look for error log files in

  • Well, I just use a VPS with 1G RAM - 1 Core - 20GB... Just for personal sites... *I dont think thats the problem the first time I added the website it worked for a few hours like the site for panel access after that I just get 503...

    Turned on PHP errors readded the website and this is what I got from the error.log in /usr/local/lsws/logs/

    2019-02-13 23:20:35.072151 [INFO] Tried to add new context: URI /install/ location /home/mywebsite/public_html/install/, result 0x1706540
    2019-02-13 23:20:35.963891 [INFO] Tried to add new context: URI /assets/ location /home/mywebsite/public_html/assets/, result 0x1706c90
    2019-02-13 23:20:35.964016 [INFO] Tried to add new context: URI /assets/css/ location /home/mywebsite/public_html/assets/assets/css/, result 0x170f130
    2019-02-13 23:20:37.038401 [INFO] Tried to add new context: URI /assets/js/ location /home/mywebsite/public_html/assets/assets/js/, result 0x170f7c0
    2019-02-13 23:20:42.238426 [INFO] Tried to add new context: URI /assets/webfonts/ location /home/mywebsite/public_html/assets/assets/webfonts/, result 0x1710410
    2019-02-13 23:20:54.507244 [INFO] Tried to add new context: URI /assets/img/ location /home/mywebsite/public_html/assets/assets/img/, result 0x1710050
    2019-02-13 23:21:48.248837 [INFO] Tried to add new context: URI /admin/ location /home/mywebsite/public_html/admin/, result 0x17104a0
  • Hi Klauser,
    Did you solve this problem? Because I have same problem and I couldn't find any solution.
  • Me too, I have the same problem as you and I couldn't find any solutions.
  • I had a similar issue but it turned out to be the lscache plugin, it didn’t like a specific setting
  • edited June 2019
    source /usr/local/CyberCP/bin/activate
    pip install --ignore-installed -r /usr/local/CyberCP/requirments.txt
    virtualenv --system-site-packages /usr/local/CyberCP
    systemctl restart gunicorn.socket
    This one has solved my problem.
  • have been having this issue for at least 6 months now. am about to switch back to wordops because I'm tired of logging into ssh and rebooting the server to fix the 503 error (happens on multiple sites on the same server).

    i have 4gb of ram, 2 cpus on my vps. plenty of resources for my websites (htop shows little resource usage during normal use).

    then randomly I see 503 errors when checking the backend or frontend of my wordpress websites

    it's started to negatively impact my google search rankings because google is sending people to a 503 errors.

    how has this gone for so long without a fix?
  • Have you considered this may be an openlitespeed issue which you need to raise on their forum Endda?
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    You can now earn with the Cyberhosting affiliate scheme. Join today
  • Same here, please help!!
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!