404 Not Found — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

404 Not Found

Hello, a domain introduced in the last hours the 404 error on all pages, including a / wp-admin. I have already tried renaming the .htaccess file but it did not work. How should I proceed?

Comments

  • 1. try place a phpinfo file in this domain , and try if it works

    2. after you changed htaccess, if you are on OLS, you will need to restart OLS to take effect.
  • Upload the phoinfo.php file to the root of the domain but the 404 error still continues.

    What would OLS be?
  • ops...OlS litespeed. ok
  • edited February 2019
    can you visit the site via HTTP (without https) ?

    Need to make sure that it only happens on https, if so then maybe domain is not mapped to SSL listener. In that case, you can

    open /usr/local/lsws/conf/httpd_config.conf

    Find listener SSL

    and inside brackets create a map entry like this
      map                     yourdomain.com yourdomain.com
    save and do systemctl restart lsws

    Finally it may look like
    listener SSL {
    address *:443
    secure 0
    map yourotherdomains.com yourotherdomains.com
    map yourdomain.com yourdomain.com

    }
  • Thanks, I noticed that the domain was not listed with the others in httpd_config.conf.
    I entered the domain according to your guidelines and went back to work, Thank you very much for your help.
  • https://cyberpanel.site84.com/cyberpanel-404-not-found-error-on-all-websites-in-server/

    i know my response is two years late but hear me out this is the solution
    this happened to me out of the blue on all my websites and i was devastated
    i dont even use ssl for any of my websites and suddenlly after installing a wordpress site and some plugins with it i got the 404 on all sites(about 8) on that server
    luckily after talking to lots of great guys and gals and tedious hours if searching for a solution here is wht worked for me

    FIRST RUN THE BELOW COMMAND
    /usr/local/lsws/bin/openlitespeed -t

    IF THERE IS AN ERROR DETECTED IN YOUR CONFIGURATIONS THEN IT WILL BE SHOWN HERE
    and i got the following result
    2020-12-22 12:35:14.419972 [WARN] [PlainConf] [module:cache] parseFile find '{' and '}' do not match in the end of file /usr/local/lsws/conf/httpd_config.conf, rootTag httpServerConfig

    SO Now As you can see the above result says that there is an error in /usr/local/lsws/conf/httpd_config.conf

    So now go ahead and get your hands on that file and go through it thoroughly , for me the error was that inside the file at line 250 , There was a lot of "NULL NULL NULL NULL NULL"
    so i just deleted it and correctly indented it and boom all my sites started working again
    YAY
    https://discord.gg/g8k8Db3 - (join the discord community for cyberpanel)
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!