Problem installing cyberpanel on 18.04 (mysql error) — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Problem installing cyberpanel on 18.04 (mysql error)

Hi, i've been trying to install cyberpanel cause i'm looking for an admin panel that functions good. I've tried ISPConfig and i'm curious about cyberpanel.

Now i've had a error before but i fixed that through the right dependencies.. now last error before it's all fixed is the mysql root password change that doesn't work..

See below:

Provider: Trans-iX

System: Ubuntu 18.04 ...etc

Installation option:

OLS or Enterprise?
OLS

Installing from official server or mirror server?
Tried both


Replace JS/CSS files to JS Delivr?
no

Install Memcached extension for PHP?
Yes

Install LiteSpeed Memcached?
Yes

Install Memcached?
Ye

Install Redis extension for PHP?
yes

Install Redis?
yes


Problem:

I've been trying to install it multiple times.. didn't work. Every time i need to delete the /etc/cyberpanel folder and the install folder..

The error that comes up now is:

[03-43-00-Mon-Feb-2019] MYSQL Root Password change. [changeMYSQLRootPassword]

[03-43-00-Mon-Feb-2019] #########################################################################

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)



[03-43-00-Mon-Feb-2019] #########################################################################

[03-43-00-Mon-Feb-2019] MYSQL Root Password change. failed, trying again, try number: 1

[03-43-00-Mon-Feb-2019] #########################################################################

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)



[03-43-00-Mon-Feb-2019] #########################################################################

[03-43-00-Mon-Feb-2019] MYSQL Root Password change. failed, trying again, try number: 2

[03-43-00-Mon-Feb-2019] #########################################################################

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)



[03-43-00-Mon-Feb-2019] #########################################################################

[03-43-00-Mon-Feb-2019] MYSQL Root Password change. failed, trying again, try number: 3

[03-43-00-Mon-Feb-2019] #########################################################################




[03-43-00-Mon-Feb-2019] #########################################################################

[03-43-00-Mon-Feb-2019] [ERROR] We are not able to MYSQL Root Password change. return code: 1. Fatal error, see /var/log/installLogs.txt for full details [changeMYSQLRootPassword]

[03-43-00-Mon-Feb-2019] #########################################################################

I've been looking around to find a workaround to get the install to finish..

Any tips or tricks how to finish it on ubuntu 18.04.

Thanks in advance guys.

Comments

  • edited February 2019
    Was that a fresh Ubuntu install, with no LAMP stack already installed? Also, mention your virtualization type.
  • Hi, this was a fresh Ubuntu install, nothing installed. Everything fresh and clean.

    Uhh think hardware virtualization, through Hyper v
  • Use KVM (recommended) or OpenVZ.
  • Oké, but that shouldn't be the big problem for mysql issue for installing cyberpanel?
  • To be honest, I've never tested CyberPanel on Hyber V, so can't say much.
  • if you manually install mariadb 10.1 on clean ubuntu and start it up , will you get any issue ?
  • Hmm I didn't try that, don't know if the install works when manual install mariadb, it looks like it goes into error when the script is trying to change the root password.. I've tried to find the part where it tries to change the password but couldn't find it, maybe if I can let the script skip the change root mysql password part it will go successfully?

    I'm just hoping to get it working on Ubuntu.. Else im forced to go for centos?
  • I've tried to install it on ubuntu 16.04, now i've come quite far.. it now crashes the installer on this:

    I think cyberpanel is no where near working state for ubuntu. Quite sad cause i think ubuntu is the better platform :-)

    See this error.
    [10-41-49-Tue-Feb-2019] [ERROR] We are not able to CyberPanel Migrate return code: 1. Fatal error, see /var/log/installLogs.txt for full details [download_install_CyberPanel]

    I've tried alot of things to make it work, no succes..
  • Now, i see it isn't possible to restart installation because it already placed files everywhere. That did cause the can't change root password too.

    I'm forced to reinstall ubuntu after a failed install. Well thats a really long road to take if the installer fails every time :-(
  • You can't do a snapshot or something ?
  • I've installed centos7, and after that cyberpanel installed perfect. So it's a Ubuntu issue.

    Now I've copied a bootstrap website with some jquery stuff. Sadly it's layout isn't Wat is used to be. Could be something with litespeed?
  • edited February 2019
    He Guys,

    Cyberpanel is finally working. Sad there isn't alot that can be configured in the control panel.. ah well it runs.
    Looks good, i've setup a wordpress website, that did look decent, nothing weird to see.

    Now i've moved over 1 of my bootstrap websites. On the server it was running(apache DA server) it ran fine, nothing weird.

    Now i've copied over the directory.
    sadly the website's layout all messed up, looks like jquery can't work?

    Errors:

    Uncaught SyntaxError: Unexpected number
    bootstrap.bundle.min.js:6 Uncaught SyntaxError: Invalid or unexpected token
    jquery.easing.min.js:1 Uncaught ReferenceError: jQuery is not defined
    at jquery.easing.min.js:1
    at jquery.easing.min.js:1
    jquery.magnific-popup.min.js:4 Uncaught SyntaxError: Invalid or unexpected token
    jqBootstrapValidation.js:912 Uncaught ReferenceError: jQuery is not defined
    at jqBootstrapValidation.js:912
    contact_me.js:1 Uncaught ReferenceError: $ is not defined
    at contact_me.js:1
    freelancer.min.js:1 Uncaught ReferenceError: jQuery is not defined
    at freelancer.min.js:1

    Website: test.mbraam.eu (this one is on cyberpanel)
    mbraam.eu = on apache. there you can see the difference..


    Any tips? Is there something missing on the server itself or is this something that has to do with cyberpanel / openlitespeed?

    Thanks for the help.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!