CyberHosting

New site always forwards to SSL

Greetings,

I have installed Cyberpanel on a fresh 18.04 server installation according to the instructions here:
https://cyberpanel.net/2018/11/19/cyberpanel-now-supports-ubuntu-18-04-and-18-10/

I logged in, and created my first website and installed Wordpress, without SSL to not complicate things too much for the beginning. I have added a hosts-entry on my local machine top reflect the bogus domain name to the internal IP of the Ubuntu box. But when I enter http://www.mydomain.com, it automatically forwards me to httpS://www.mydomain.com, which is not available, because I did not tick the SSL check box.

How can I disable this behaviour? Also for the future, if I will stick with Cyberpanel, I will not use SSL because I am sitting behind a quite beefy WAF, and the webservers are all in the DMZ.

Any help is highly appreciated,

Thanks
Guybrush

Comments

  • Check your rewrite rules, make sure you are not strictly redirecting to https version.
  • rewrite rules seem to be fine, out of the box:

    # BEGIN LSCACHE
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##

    RewriteEngine on
    CacheLookup on
    RewriteRule .* - [E=Cache-Control:no-autoflush]
    RewriteRule ^min/\w+\.(css|js) - [E=cache-control:no-vary]

    ### marker CACHE RESOURCE start ###
    RewriteRule wp-content/.*/[^/]*(responsive|css|js|dynamic|loader|fonts)\.php - [E=cache-control:max-age=3600]
    ### marker CACHE RESOURCE end ###

    ### marker FAVICON start ###
    RewriteRule favicon\.ico$ - [E=cache-control:max-age=86400]
    ### marker FAVICON end ###


    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    # END LSCACHE
    # BEGIN NON_LSCACHE
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    ### marker MINIFY start ###

    RewriteEngine on
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} ^(.*)/min/(\w+)\.(css|js)$
    RewriteCond %1/wp-content/cache/$2/$1.$2 -f
    RewriteRule min/(\w+)\.(css|js) wp-content/cache/$2/$1.$2 [L]

    ### marker MINIFY end ###

    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    # END NON_LSCACHE

    seems to be something wordpress specific - if I call the index.html, everything is fine. if i go for index.php, it tries to forward me to the ssl page. i also tried to rename all the .ht* in the root dir, without any change....
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!