remote backup problems

Main and Backup KVM VPS:
Centos 7.6
OLS
cyberpanel 1.8.1



Since previous versions having this remote daily backup problem:

[07-00-08-Mon-Mar-2019] Domains matching query does not exist.
[07-02-51-Mon-Mar-2019] get() returned more than one Backups -- it returned 2! [backupStatus]
[07-02-51-Mon-Mar-2019] [Errno 2] No such file or directory: '/home/domain.com/backup/backup-domain-07-00-06-Mon-Mar-2019' [startBackup]
[07-02-51-Mon-Mar-2019] coercing to Unicode: need string or buffer, file found [statusWriter]

whenever i get Errno 2, going to backup vps there's no backup file in the said directory (in this case, Mon-Mar).

Comments

  • Just so you know, we are currently working to resolve issues with remote backups, will make a release as soon as it is tested and fixed.
  • > @CyberPanel said:
    > Just so you know, we are currently working to resolve issues with remote backups, will make a release as soon as it is tested and fixed.

    Noted with thanks. Appreciate the work.
  • @cybertech

    Just pushed another fix, kindly force upgrade and let us know if you face any further issues.

    Note: Re-add your destinations.
  • edited March 6

    @cybertech

    Just pushed another fix, kindly force upgrade and let us know if you face any further issues.

    Note: Re-add your destinations.

    just forced upgrade and removed / re-added destinations.

    will report back in around 15hours.
  • Today remote backup worked with no errno message. Thanks. Hope this stays.
  • edited March 8
    Today remote backup did not work:

    [07-02-01-Thu-Mar-2019] [Errno 2] No such file or directory: '/home/domain.com/backup/backup-domain-07-00-04-Thu-Mar-2019/meta.xml' [startBackup]
    [07-02-01-Thu-Mar-2019] coercing to Unicode: need string or buffer, file found [statusWriter]
    [07-02-01-Thu-Mar-2019] [Errno 2] No such file or directory: '/home/domain.com/backup/backup-domain-07-00-04-Thu-Mar-2019/meta.xml' [startBackup]
  • Sometimes internally logs are generated but does not mean the job is failed, can you confirm if the backups are not actually available on the backup server?
  • Sometimes internally logs are generated but does not mean the job is failed, can you confirm if the backups are not actually available on the backup server?

    yes, i did check that it is not available on backup server.

    backup server also runs freshly installed cyberpanel.

    anyhow i have re-added destination again. will report back again in 15hours.
  • checked and saw the backups in for 3 days. it should be working fine.

    past 2 days there was no Errno error.
  • Problem is back, did not receive the backup:

    [07-02-08-Tue-Mar-2019] [Errno 2] No such file or directory: '/home/domain.com/backup/backup-domain-07-00-04-Tue-Mar-2019' [startBackup]
    [07-02-08-Tue-Mar-2019] coercing to Unicode: need string or buffer, file found [statusWriter]
    [07-02-08-Tue-Mar-2019] [Errno 2] No such file or directory: '/home/domain.com/backup/backup-domain-07-00-04-Tue-Mar-2019' [startBackup]
    [07-02-09-Tue-Mar-2019] get() returned more than one Backups -- it returned 3! [backupStatus]
    [07-02-09-Tue-Mar-2019] get() returned more than one Backups -- it returned 3! [backupStatus]
    [07-02-09-Tue-Mar-2019] get() returned more than one Backups -- it returned 3! [backupStatus]
  • Can you try to create a manual backup of this domain directly via control panel, let me know if you face any issues.
  • Can you try to create a manual backup of this domain directly via control panel, let me know if you face any issues.

    It works , I can see the file in /home/domain/backup folder

    Did not try to restore.

    Noticed that in this menu I could see the whole list of backup history; a mixture of "completed" and "pending" backup file names.
  • edited March 13
    OK, when scheduled backups are run they also generate backup logs in /usr/local/lscp/logs/backup_log. Date Here

    Can you find and provide logs from the day you started having this error.
  • There seem to be minor issues with the code that send schedule backups. Since you did not share your backup logs yet, I fixed those issues and pushed the package.

    You can upgrade and see if this fixes your issue. Otherwise, provide logs as asked above.
  • edited March 14
    I will try the upgrade in a day. Meanwhile there arent as many logs as the backup job IDs seen on the panel. Currently I have 43 backup IDs with a mixture of "Completed" and "Pending".

    The logs seem to be merged or overwritten I'm not sure:

    GNU nano 2.3.1 File: backup_log.07-00-02-Thu-Mar-2019
    [07-00-02-Thu-Mar-2019] #################################################
    [07-00-02-Thu-Mar-2019] Backup log for: 07-00-02-Thu-Mar-2019
    [07-00-02-Thu-Mar-2019] #################################################

    [07-00-02-Thu-Mar-2019]
    [07-00-02-Thu-Mar-2019]
    [07-00-02-Thu-Mar-2019] ################################################# [07-00-02-Thu-Mar-2019] Backup log for: 07-00-02-Thu-Mar-2019
    [07-00-02-Thu-Mar-2019] #################################################

    [07-00-02-Thu-Mar-2019]
    [07-00-02-Thu-Mar-2019]
    [07-00-04-Thu-Mar-2019] Preparing to create backup for: domain.com
    [07-00-04-Thu-Mar-2019] Backup started for: domain.com
    [07-00-04-Thu-Mar-2019] Starting local backup for: domain.com
    [07-00-04-Thu-Mar-2019] Preparing to create backup for: domain.com
    [07-00-04-Thu-Mar-2019] Backup started for: domain.com
    [07-00-04-Thu-Mar-2019] Starting local backup for: domain.com
    [07-00-06-Thu-Mar-2019] Waiting for backup to complete..
    [07-00-06-Thu-Mar-2019] Waiting for backup to complete..
    [07-02-20-Fri-Mar-2019] Backup Completed for: domain.com
    [07-02-20-Fri-Mar-2019] Backup created for: domain.com
    [07-02-20-Fri-Mar-2019] Preparing to send backup for: domain.com to XXX.X$[07-02-21-Fri-Mar-2019] Backup Completed for: domain.com
    [07-02-21-Fri-Mar-2019] Backup created for: domain.com
    [07-02-21-Fri-Mar-2019] Preparing to send backup for: domain.com to XXX.X$[07-02-21-Fri-Mar-2019] Backup for: domain.com is sent to XXX.XXX.X.XXX
    [07-02-21-Fri-Mar-2019]
    [07-02-21-Fri-Mar-2019]
    [07-02-21-Fri-Mar-2019] #################################################
    [07-02-21-Fri-Mar-2019] [07-02-21-Fri-Mar-2019]
    [07-02-21-Fri-Mar-2019] Remote backup job completed.
    [07-02-22-Fri-Mar-2019] Backup for: domain.com is sent to XXX.XXX.X.XXX
    [07-02-22-Fri-Mar-2019]
    [07-02-22-Fri-Mar-2019]
    [07-02-22-Fri-Mar-2019] #################################################
    [07-02-22-Fri-Mar-2019]
    [07-02-22-Fri-Mar-2019]
    [07-02-22-Fri-Mar-2019] Remote backup job completed.
  • It seems it failed on second domain, anyhow try the upgrade and let me know if there are any issues.

    Also for each backup job, there is only 1 log file. (1 log file /day)
  • edited March 15
    there is only one domain on this server. the above is pasted from a single log file.

    already upgraded, will report back again.

    right now the manual remote back up does not work, after creating the local back up it does not send to backup VPS.
  • @cybertech

    Can you kindly create a ticket with us, I would like to personally check backup logs and some other things.
  • Ticket created. Thanks.
  • Thanks to excellent support by @CyberPanel , remote scheduled automatic daily backups work without hiccups for past 6 days or so.

    Regarding automated backup it is now working very well.

    have not seen "Errno" errors in cyberpanel log nor random errors in error log. seems much improved.

    the only thing that still unable to decipher is , how to read the date of the backup file as like below:
    "backup-domain-07-00-04-Thu-Mar-2019"

    Because the backup files will create the DAY folder in backup server, over a few weeks you can receive many of these backup files under "Thu-Mar".

    so far one way to see which is latest is by going to main server and check under "Create Backup" you can see list of previously backed up files and their status.

    another way is go to backup folder and do ls -lu


  • as for manual remote backup (transfer from server to server) it can only work in SSH port 22.

    if receiving server is not Port 22 is not work.

    if possible it will be nice to also include possible to change port as well (same like automated scheduled backup, u can specify port )

    good for security, i think.
Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!