CyberHosting

Increase LSAPI_CHILDREN

edited March 27 in Web Interface
Hello,

I see the following in my stderr.log hundreds of times.
[7768] Reached max children process limit: 5, extra: 1, current: 6, busy: 6, please increase LSAPI_CHILDREN.
so I would like to increase my LSAPI_CHILDREN.

My website's vHost conf doesn't contain any line with LSAPI_CHILDREN, is there any other location I can check?

PS: I'm using CyberPanel Enterprise 1.8.1

Thanks,
George

Comments

  • Hello

    If on the command line you do

    cat /usr/local/lsws/conf/httpd_config.xml | grep LSAPI_CHILDREN

    You will see value of PHP_LSAPI_CHILDREN. You can open this file via nano or vi editor and edit this parameter and restart LiteSpeed, you can also do this via Webadmin. An example of output of the above command is
    cat /usr/local/lsws/conf/httpd_config.xml | grep LSAPI_CHILDREN
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
    PHP_LSAPI_CHILDREN=35
  • edited March 31
    there is also a parameter

    phpSuExecMaxConn>5</phpSuExecMaxCon

    in httpd_config.xml

    need to change 5 to higher number.
  • edited May 29
    Thanks, it was phpSuExecMaxConn after all ;)
Sign In or Register to comment.
CyberHosting CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!