CyberHosting

Installation Error.

I am getting error on installation, can anyone help ?

`[07-59-18-Mon-Feb-2018] #########################################################################

[07-59-18-Mon-Feb-2018] Trying to start PureFTPD instance, trying again, try number: 2

[07-59-18-Mon-Feb-2018] #########################################################################

Job for pure-ftpd.service failed because the control process exited with error code. See "systemctl status pure-ftpd.service" and "journalctl -xe" for details.
`

from log

[07-59-17-Mon-Feb-2018] PureFTPD configured!
[07-59-18-Mon-Feb-2018] Failed to start PureFTPD instance, exiting installer! [startPureFTPD]

Comments

  • LXC is not supported, please use KVM , OpenVZ or dedicated server.

  • I'm trying to install Cyberpanel stable but error : CyberPanel installation failed.


    [10-46-46-Fri-Aug-2018] ######################################################## #################

    [10-46-46-Fri-Aug-2018] Python development tools successfully installed!

    [10-46-46-Fri-Aug-2018] ######################################################## #################

    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * epel: fedora.cu.be
    Resolving Dependencies
    --> Running transaction check
    ---> Package gcc.x86_64 0:4.8.5-28.el7_5.1 will be installed
    --> Processing Dependency: cpp = 4.8.5-28.el7_5.1 for package: gcc-4.8.5-28.el7_ 5.1.x86_64
    --> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.8.5-28.el 7_5.1.x86_64
    --> Processing Dependency: libmpfr.so.4()(64bit) for package: gcc-4.8.5-28.el7_5 .1.x86_64
    --> Processing Dependency: libmpc.so.3()(64bit) for package: gcc-4.8.5-28.el7_5. 1.x86_64
    --> Running transaction check
    ---> Package cpp.x86_64 0:4.8.5-28.el7_5.1 will be installed
    ---> Package glibc-devel.x86_64 0:2.17-222.el7 will be installed
    --> Processing Dependency: glibc-headers = 2.17-222.el7 for package: glibc-devel -2.17-222.el7.x86_64
    --> Processing Dependency: glibc-headers for package: glibc-devel-2.17-222.el7.x 86_64
    ---> Package libmpc.x86_64 0:1.0.1-3.el7 will be installed
    ---> Package mpfr.x86_64 0:3.1.1-4.el7 will be installed
    --> Running transaction check
    ---> Package glibc-headers.x86_64 0:2.17-222.el7 will be installed
    --> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2. 17-222.el7.x86_64
    --> Processing Dependency: kernel-headers for package: glibc-headers-2.17-222.el 7.x86_64
    --> Finished Dependency Resolution
    Error: Package: glibc-headers-2.17-222.el7.x86_64 (base)
    Requires: kernel-headers >= 2.2.1
    Error: Package: glibc-headers-2.17-222.el7.x86_64 (base)
    Requires: kernel-headers
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest



    [10-46-50-Fri-Aug-2018] ######################################################## #################

    [10-46-50-Fri-Aug-2018] Unable to install GCC, trying again, try number: 1

    [10-46-50-Fri-Aug-2018] ######################################################## #################

    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * epel: fedora.cu.be
    Resolving Dependencies
    --> Running transaction check
    ---> Package gcc.x86_64 0:4.8.5-28.el7_5.1 will be installed
    --> Processing Dependency: cpp = 4.8.5-28.el7_5.1 for package: gcc-4.8.5-28.el7_ 5.1.x86_64
    --> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.8.5-28.el 7_5.1.x86_64
    --> Processing Dependency: libmpfr.so.4()(64bit) for package: gcc-4.8.5-28.el7_5 .1.x86_64
    --> Processing Dependency: libmpc.so.3()(64bit) for package: gcc-4.8.5-28.el7_5. 1.x86_64
    --> Running transaction check
    ---> Package cpp.x86_64 0:4.8.5-28.el7_5.1 will be installed
    ---> Package glibc-devel.x86_64 0:2.17-222.el7 will be installed
    --> Processing Dependency: glibc-headers = 2.17-222.el7 for package: glibc-devel -2.17-222.el7.x86_64
    --> Processing Dependency: glibc-headers for package: glibc-devel-2.17-222.el7.x 86_64
    ---> Package libmpc.x86_64 0:1.0.1-3.el7 will be installed
    ---> Package mpfr.x86_64 0:3.1.1-4.el7 will be installed
    --> Running transaction check
    ---> Package glibc-headers.x86_64 0:2.17-222.el7 will be installed
    --> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2. 17-222.el7.x86_64
    --> Processing Dependency: kernel-headers for package: glibc-headers-2.17-222.el 7.x86_64
    --> Finished Dependency Resolution
    Error: Package: glibc-headers-2.17-222.el7.x86_64 (base)
    Requires: kernel-headers >= 2.2.1
    Error: Package: glibc-headers-2.17-222.el7.x86_64 (base)
    Requires: kernel-headers
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest



    [10-46-53-Fri-Aug-2018] ######################################################## #################

    [10-46-53-Fri-Aug-2018] Unable to install GCC, trying again, try number: 2

    [10-46-53-Fri-Aug-2018] ######################################################## #################

    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * epel: fedora.cu.be
    Resolving Dependencies
    --> Running transaction check
    ---> Package gcc.x86_64 0:4.8.5-28.el7_5.1 will be installed
    --> Processing Dependency: cpp = 4.8.5-28.el7_5.1 for package: gcc-4.8.5-28.el7_ 5.1.x86_64
    --> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.8.5-28.el 7_5.1.x86_64
    --> Processing Dependency: libmpfr.so.4()(64bit) for package: gcc-4.8.5-28.el7_5 .1.x86_64
    --> Processing Dependency: libmpc.so.3()(64bit) for package: gcc-4.8.5-28.el7_5. 1.x86_64
    --> Running transaction check
    ---> Package cpp.x86_64 0:4.8.5-28.el7_5.1 will be installed
    ---> Package glibc-devel.x86_64 0:2.17-222.el7 will be installed
    --> Processing Dependency: glibc-headers = 2.17-222.el7 for package: glibc-devel -2.17-222.el7.x86_64
    --> Processing Dependency: glibc-headers for package: glibc-devel-2.17-222.el7.x 86_64
    ---> Package libmpc.x86_64 0:1.0.1-3.el7 will be installed
    ---> Package mpfr.x86_64 0:3.1.1-4.el7 will be installed
    --> Running transaction check
    ---> Package glibc-headers.x86_64 0:2.17-222.el7 will be installed
    --> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2. 17-222.el7.x86_64
    --> Processing Dependency: kernel-headers for package: glibc-headers-2.17-222.el 7.x86_64
    --> Finished Dependency Resolution
    Error: Package: glibc-headers-2.17-222.el7.x86_64 (base)
    Requires: kernel-headers >= 2.2.1
    Error: Package: glibc-headers-2.17-222.el7.x86_64 (base)
    Requires: kernel-headers
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest



    [10-46-57-Fri-Aug-2018] ######################################################## #################

    [10-46-57-Fri-Aug-2018] Unable to install GCC, trying again, try number: 3

    [10-46-57-Fri-Aug-2018] ######################################################## #################




    [10-46-57-Fri-Aug-2018] ######################################################## #################

    [10-46-57-Fri-Aug-2018] Installation failed, consult: /var/log/installLogs.txt

    [10-46-57-Fri-Aug-2018] ######################################################## #################

    CyberPanel installation failed.

  • Mention:

    VIrtualization.
    Operating system.
  • Hello,

    I have an installation failure as well on CentOS VirtualBox Windows

    Transaction Summary
    ================================================================================
    Install 2 Packages (+2 Dependent packages)

    Total download size: 3.4 M
    Installed size: 12 M
    Downloading packages:
    (1/4): luajit-2.0.4-3.el7.x86_64.rpm | 343 kB 00:00
    (2/4): pdns-backend-mysql-0.0.2401g849c452-1pdns.el7.x86_6 | 38 kB 00:00
    (3/4): libsodium-1.0.16-1.el7.x86_64.rpm | 140 kB 00:00
    (4/4): pdns-0.0.2401g849c452-1pdns.el7.x86_64.rpm | 2.9 MB 00:01
    --------------------------------------------------------------------------------
    Total 2.1 MB/s | 3.4 MB 00:01
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    Installing : luajit-2.0.4-3.el7.x86_64 1/4
    Installing : libsodium-1.0.16-1.el7.x86_64 2/4
    Installing : pdns-0.0.2401g849c452-1pdns.el7.x86_64 3/4
    Installing : pdns-backend-mysql-0.0.2401g849c452-1pdns.el7.x86_64 4/4
    Verifying : pdns-backend-mysql-0.0.2401g849c452-1pdns.el7.x86_64 1/4
    Verifying : libsodium-1.0.16-1.el7.x86_64 2/4
    Verifying : luajit-2.0.4-3.el7.x86_64 3/4
    Verifying : pdns-0.0.2401g849c452-1pdns.el7.x86_64 4/4

    Installed:
    pdns.x86_64 0:0.0.2401g849c452-1pdns.el7
    pdns-backend-mysql.x86_64 0:0.0.2401g849c452-1pdns.el7

    Dependency Installed:
    libsodium.x86_64 0:1.0.16-1.el7 luajit.x86_64 0:2.0.4-3.el7

    Complete!



    [11-19-38-Mon-Aug-2018] #########################################################################

    [11-19-38-Mon-Aug-2018] PowerDNS successfully installed!

    [11-19-38-Mon-Aug-2018] #########################################################################




    [11-19-38-Mon-Aug-2018] #########################################################################

    [11-19-38-Mon-Aug-2018] Configuring PowerDNS..

    [11-19-38-Mon-Aug-2018] #########################################################################




    [11-19-38-Mon-Aug-2018] #########################################################################

    [11-19-38-Mon-Aug-2018] PowerDNS configured!

    [11-19-38-Mon-Aug-2018] #########################################################################

    Created symlink from /etc/systemd/system/multi-user.target.wants/pdns.service to /usr/lib/systemd/system/pdns.service.



    [11-19-39-Mon-Aug-2018] #########################################################################

    [11-19-39-Mon-Aug-2018] PowerDNS successfully enabled at system restart!

    [11-19-39-Mon-Aug-2018] #########################################################################

    Job for pdns.service failed because the control process exited with error code. See "systemctl status pdns.service" and "journalctl -xe" for details.



    [11-19-39-Mon-Aug-2018] #########################################################################

    [11-19-39-Mon-Aug-2018] Trying to start PowerDNS instance, trying again, try number: 2

    [11-19-39-Mon-Aug-2018] #########################################################################

    Job for pdns.service failed because the control process exited with error code. See "systemctl status pdns.service" and "journalctl -xe" for details.



    [11-19-41-Mon-Aug-2018] #########################################################################

    [11-19-41-Mon-Aug-2018] Trying to start PowerDNS instance, trying again, try number: 3

    [11-19-41-Mon-Aug-2018] #########################################################################




    [11-19-41-Mon-Aug-2018] #########################################################################

    [11-19-41-Mon-Aug-2018] Installation failed, consult: /var/log/installLogs.txt

    [11-19-41-Mon-Aug-2018] #########################################################################

    CyberPanel installation failed.
  • please run `systemctl status pdns.service` and post result
  • Hello,

    will be LXC supported by CyberPanel? It will be nice :)

    Regards,
  • > @mgregors said:
    > Hello,
    >
    > will be LXC supported by CyberPanel? It will be nice :)
    >
    > Regards,

    Unfortunately, due to its restrictions and limitations, some of essential software can not be installed or configured on LXC
  • May I ask what restrictions you mean exactly? Where are the problems with LXD/LXC?
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!