CyberHosting

Python v2.7.x will be retired soon (end of support)

edited May 2019 in Updates
It seems Python v2.7.x which was around since 2008 will be discontinued soon. Cyberpanel is based on this version, correct?

https://www.python.org/dev/peps/pep-0373/#maintenance-releases

https://pythonclock.org

So, similar to Windows 7, in Jan 2020, no more bug fixes, no patches, nothing.

Are there plans to migrate CyberPanel to Python v3.x ?

If so, what is the timeline?

Comments

  • Soon, but no final date yet.
  • OK, we are now 1 month away from 2.7.x discontinuation. Updates to Cyberpanel?
  • Will not stop. Python 2.7 libraries are not going anywhere. It wont be removed they are just no longer supporting 2.7 at all.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • Yes, but same like my Windows 7 example above, this means no bug fixes, no security patches, no performance improvements, etc., all of which are very important in server environments.
  • https://access.redhat.com/solutions/4455511 red hat will still support python 2.7 until 2024 in its build which in turn will be passed to centos 7. I imagine canonical will take the same stance for ubuntu.

    Quote from that link

    Just because the PSF consider Python 2 "unsupported" does not mean that Python 2 is "unsupported" within RHEL.
  • This is strange, Python 3.x was available since 2008, why are so many developers sticking with 2.7 in 2019?

    https://www.techrepublic.com/article/migrating-from-python-2-to-python-3-a-guide-to-preparing-for-the-2020-deadline/

    It seems, most of the code can be converted automatically from 2.7 to 3.x. But thoroughly testing it, yeah, that's going to be quite a challenge as CyberPanel contains a lot of code.
  • This branch is all about Python 3 and Centos 8. -> https://github.com/usmannasir/cyberpanel/tree/p3

    But I think there are 1000s of project still using 2.7.5 (serious projects). So it is not very easy to retire 2.7.5 like that.

    I am working on python 3, but it may take time, as I am already faced with some issues.
  • edited December 2019
    OK, we are now 1 month away from 2.7.x discontinuation. Updates to Cyberpanel?
    https://techandskill.com/watch-cartoons-online/
  • edited December 2019
    > @CyberPanel said:
    > But I think there are 1000s of project still using 2.7.5 (serious projects). So it is not very easy to retire 2.7.5 like that.
    >
    > I am working on python 3, but it may take time, as I am already faced with some issues.

    Understandable. That said, just several years ago, many of the most significant Python packages in existence which are on this list were red, and now over 90% (nearly all) are now green, meaning they are ready. In fact, there are millions of Python projects (applications and packages) in the world today and many of them are ready. I am not trying to scare but to inspire you by showing that a large portion of them have underseen preparations some time ago:

    https://python3wos.appspot.com/
  • @Hifihedgehog

    I partially agree with you. Personally, in some offices I still see Windows XP being used, as their company software is based on that version of windows.

    The information you online is correct, but don't believe that this is sudden death of Python 2.x.

    Even most of CloudLinux component are based on python 2.x.

    That said we already have running CyberPanel on Python 3 and Centos 8, more information here -> https://forums.cyberpanel.net/discussion/3376/installing-cyberpanel-with-python-3
This discussion has been closed.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!