Unable to update to CyberPanel 1.8.3 on CentOS 7.6 (ImportError: No module named)

Hi,
Just received the mail about the new version of CyberPanel.
I found the commands to update on the docs.
After try, I have an error message:
File "/usr/lib/python2.7/site-packages/requests/packages/__init__.py", line 95, in load_module
raise ImportError("No module named '%s'" % (name,))
ImportError: No module named 'requests.packages.urllib3'
Full message can be seen here: https://imgur.com/BSolbHv
My hosting is on CentOS Linux release 7.6.1810 (Core).
Any idea?
Thank you in advance!
Regards

Comments

  • You can install urllib3 and try to upgrade again pip install urllib3
  • Hi, thanks for the command.
    I tried, it says that it's already installed. But with this command
    pip install urllib3 --upgrade
    it helped to upgrade this "component" and after that, it was possible to make the update.
    Ticket closed!
    Thank you and have a great day!
Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!