CyberHosting

SSL Issue Not Working Properly

Hi,

I can't run SSL as Let's Encrypt by website list or SSL Menu > Manage SSL or command line. SSL issue looks like working when forced but as an matter of fact, not working for websites. All websites are down because of unsecure connection. What can i do?

Comments

  • Do you have a rewrite rule that force https or somewhere in your application it force the https version?

    If so I believe that is why verification is failing. But I didn't understand your point, SSL issued successfully from CyberPanel? what does the main log file says?
  • Yes, i'm using a wordpress plugin for all of my sites forced http to https. I'm trying plugin to deavtive but there are not changes anything. Problem appeared yesterday. There was no such like this problem before.

    Latest logs:

    [09-24-38-Mon-Jun-2019] Trying to obtain SSL for: XXX.XX and: www.XXX.XX
    [09-24-42-Mon-Jun-2019] Failed to obtain SSL for: XXX.XX and: www.XXX.XX
    [09-24-42-Mon-Jun-2019] Trying to obtain SSL for: XXX.XX
    [09-24-51-Mon-Jun-2019] Successfully obtained SSL for: XXX.XX
    [09-25-11-Mon-Jun-2019] No JSON object could be decoded
    [09-27-02-Mon-Jun-2019] Trying to obtain SSL for: YYY.YY and: www.YYY.YY
    [09-27-05-Mon-Jun-2019] Failed to obtain SSL for: YYY.YY and: www.YYY.YY
    [09-27-05-Mon-Jun-2019] Trying to obtain SSL for: YYY.YY
    [09-27-13-Mon-Jun-2019] Successfully obtained SSL for: YYY.YY

    I think logs are not enough.
  • What is your site URL?
  • Okay i have a new error message about ssl. I reached lets encrypt limits. I think my server have a few problems and i'm deactive server for a clean one. You may close the thread, thanks a lot.

    Cannot issue SSL. Error message: [Mon Jun 10 09:53:12 UTC 2019] Create new order error. Le_OrderFinalize not found. { "type": "urn:ietf:params:acme:error:rateLimited", "detail": "Error creating new order :: too many certificates already issued for exact set of domains: XXX.XX,www.XXX:XX: see https://letsencrypt.org/docs/rate-limits/", "status": 429 } [Mon Jun 10 09:53:12 UTC 2019] Please add '--debug' or '--log' to check more details. [Mon Jun 10 09:53:12 UTC 2019] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh [Mon Jun 10 09:53:14 UTC 2019] Create new order error. Le_OrderFinalize not found. { "type": "urn:ietf:params:acme:error:rateLimited", "detail": "Error creating new order :: too many certificates already issued for exact set of domains: XXX.XX: see https://letsencrypt.org/docs/rate-limits/", "status": 429 } [Mon Jun 10 09:53:14 UTC 2019] Please add '--debug' or '--log' to check more details. [Mon Jun 10 09:53:14 UTC 2019] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh 0,283 Failed to obtain SSL for domain. [issueSSLForDomain]
  • Can confirm the similar issue. Sometimes SSL auto-update (LetsEncrypt) fails. When I'm trying to update the cert manually I usually face this message:
    https://imgur.com/a/X0BdmVI

    If I wait for 20 minutes and reboot server - everything works. The issue is present since 1.8.2 release. It is not critical, but very annoying.

    Here are server logs:
    2019-06-11 10:11:50.594191 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594195 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594199 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594204 [ERROR] Invalid rewrite directive: php_value always_populate_raw_post_data -1
    2019-06-11 10:11:50.594209 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594213 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594217 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594222 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/javascript
    2019-06-11 10:11:50.594227 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/rss+xml
    2019-06-11 10:11:50.594232 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    2019-06-11 10:11:50.594235 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/x-font
    2019-06-11 10:11:50.594239 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/x-font-opentype
    2019-06-11 10:11:50.594252 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/x-font-otf
    2019-06-11 10:11:50.594255 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/x-font-truetype
    2019-06-11 10:11:50.594259 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/x-font-ttf
    2019-06-11 10:11:50.594262 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE application/x-javascript
    2019-06-11 10:11:50.594266 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE font/opentype
    2019-06-11 10:11:50.594269 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE font/otf
    2019-06-11 10:11:50.594272 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE font/ttf
    2019-06-11 10:11:50.594275 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE image/svg+xml
    2019-06-11 10:11:50.594279 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE image/x-icon
    2019-06-11 10:11:50.594282 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE text/css
    2019-06-11 10:11:50.594285 [ERROR] Invalid rewrite directive: AddOutputFilterByType DEFLATE text/javascript
    2019-06-11 10:11:50.594289 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594293 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594296 [ERROR] Invalid rewrite directive: BrowserMatch ^Mozilla/4 gzip-only-text/html
    2019-06-11 10:11:50.594299 [ERROR] Invalid rewrite directive: BrowserMatch ^Mozilla/4\.0[678] no-gzip
    2019-06-11 10:11:50.594303 [ERROR] Invalid rewrite directive: BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    2019-06-11 10:11:50.594306 [ERROR] Invalid rewrite directive: Header append Vary User-Agent
    2019-06-11 10:11:50.594309 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594312 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594315 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594318 [INFO] Rewrite directive: bypassed.
    2019-06-11 10:11:50.594323 [INFO] RewriteFile [/home/mautic.existance.co/public_html/.htaccess] parsed, return 0.
    2019-06-11 10:11:50.594417 [INFO] [PlainConf] [virtualHostTemplate:] start parsing file /usr/local/lsws/conf/templates/ccl.conf
    2019-06-11 10:11:50.606397 [INFO] [PlainConf] [virtualHostTemplate:] RCS checkin config file /usr/local/lsws/conf/templates/ccl.conf0 OK.
    2019-06-11 10:11:50.606534 [INFO] [PlainConf] [context:/] rewrite [] add rules [rewritefile .htaccess]
    2019-06-11 10:11:50.606585 [INFO] [PlainConf] [virtualHostTemplate:] start parsing file /usr/local/lsws/conf/templates/phpsuexec.conf
    2019-06-11 10:11:50.618171 [INFO] [PlainConf] [virtualHostTemplate:] RCS checkin config file /usr/local/lsws/conf/templates/phpsuexec.conf0 OK.
    2019-06-11 10:11:50.618302 [INFO] [PlainConf] [context:/] rewrite [] add rules [rewritefile .htaccess]
    2019-06-11 10:11:50.618377 [INFO] [PlainConf] [virtualHostTemplate:] start parsing file /usr/local/lsws/conf/templates/rails.conf
    2019-06-11 10:11:50.629518 [INFO] [PlainConf] [virtualHostTemplate:] RCS checkin config file /usr/local/lsws/conf/templates/rails.conf0 OK.
    2019-06-11 10:11:50.629649 [INFO] [PlainConf] [context:/] rewrite [] add rules [rewritefile .htaccess]
    2019-06-11 10:11:50.629696 [NOTICE] [ZConfManager] No VHosts added, do not send!
    2019-06-11 10:11:50.630175 [NOTICE] [AutoRestarter] new child process with pid=12914 is forked!
    2019-06-11 10:11:50.630914 [NOTICE] [child: 12914] Successfully change current user to nobody
    2019-06-11 10:11:50.630958 [NOTICE] Child: 12914] Core dump is enabled.
    2019-06-11 10:11:50.631031 [NOTICE] [Child: 12914] Setup swapping space...
    2019-06-11 10:11:50.631140 [NOTICE] [Child: 12914] LiteSpeed/1.4.39 Open starts successfully!
    2019-06-11 10:12:18.351445 [INFO] Tried to add new context: URI /serverlogs/ location /home/cyberpanel.existance.co/public_html//serverlogs/, result 0xf89ec0
  • Another logs:
    [08-11-37-Tue-Jun-2019] Trying to obtain SSL for: existance.co and: www.existance.co
    [08-11-43-Tue-Jun-2019] Successfully obtained SSL for: existance.co and: www.existance.co
    [08-11-44-Tue-Jun-2019] Trying to obtain SSL for: existance.co and: www.existance.co
    [08-11-50-Tue-Jun-2019] Successfully obtained SSL for: existance.co and: www.existance.co
  • Yeah, after reboot it works.

    But the frontend drops an error.
  • Can you try private window or by manually restarting LSWS systemctl restart lsws

    Also are you accessing CyberPanel on port 8090 or did you follow this tutorial https://blog.cyberpanel.net/2018/12/25/how-to-remove-port-8090-from-cyberpanel/ ?
Sign In or Register to comment.
CyberHosting CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!