CyberHosting

PHP GD support will not enable webp

Hi All

Has anyone successfully got gd support for webp enabled?

I have installed without any issue using Apache / Nginx

OS - CentOS 7.6

Have installed all requirement + extra and gd support will not enable.

libwebp-devel is installed
- Tried with ImageMagick (webp support shows enabled)
- Have recompiled all versions of PHP 7 to get working with webadmin using:

--with-jpeg-dir=/usr/lib64/' '--with-webp-dir=/usr/lib64/' '--with-freetype-dir=/usr/lib64/' '--with-png-dir=/usr/lib64/

checking for GD support... yes
checking for the location of libwebp... /usr/lib64/
checking for the location of libjpeg... /usr/lib64/
checking for the location of libpng... /usr/lib64/
checking for the location of libXpm... no
checking for FreeType 2... /usr/lib64/
checking whether to enable truetype string function in GD... no
checking whether to enable JIS-mapped Japanese font support in GD... no
checking for WebPGetInfo in -lwebp... yes
checking for jpeg_read_header in -ljpeg... yes
checking for png_write_image in -lpng... yes

php -r 'var_dump(gd_info());'
array(12) {
["GD Version"]=>
string(26) "bundled (2.1.0 compatible)"
["FreeType Support"]=>
bool(true)
["FreeType Linkage"]=>
string(13) "with freetype"
["GIF Read Support"]=>
bool(true)
["GIF Create Support"]=>
bool(true)
["JPEG Support"]=>
bool(true)
["PNG Support"]=>
bool(true)
["WBMP Support"]=>
bool(true)
["XPM Support"]=>
bool(true)
["XBM Support"]=>
bool(true)
["WebP Support"]=>
bool(false)
["JIS-mapped Japanese Font Support"]=>
bool(false)

Any help would be appreciated.

Thanks.

Comments

  • Same OS version with apache, nginx, php 7.1.30

    php -r 'var_dump(gd_info());'
    array(12) {
    ["GD Version"]=>
    string(5) "2.2.5"
    ["FreeType Support"]=>
    bool(true)
    ["FreeType Linkage"]=>
    string(13) "with freetype"
    ["GIF Read Support"]=>
    bool(true)
    ["GIF Create Support"]=>
    bool(true)
    ["JPEG Support"]=>
    bool(true)
    ["PNG Support"]=>
    bool(true)
    ["WBMP Support"]=>
    bool(true)
    ["XPM Support"]=>
    bool(true)
    ["XBM Support"]=>
    bool(true)
    ["WebP Support"]=>
    bool(true)
    ["JIS-mapped Japanese Font Support"]=>
    bool(false)
  • Have resolved issue myself.. webp now working and enabled OLS. 1.4.47

    ["GD Version"]=>
    string(26) "bundled (2.1.0 compatible)"
    ["FreeType Support"]=>
    bool(true)
    ["FreeType Linkage"]=>
    string(13) "with freetype"
    ["GIF Read Support"]=>
    bool(true)
    ["GIF Create Support"]=>
    bool(true)
    ["JPEG Support"]=>
    bool(true)
    ["PNG Support"]=>
    bool(true)
    ["WBMP Support"]=>
    bool(true)
    ["XPM Support"]=>
    bool(true)
    ["XBM Support"]=>
    bool(true)
    ["WebP Support"]=>
    bool(true)
    ["JIS-mapped Japanese Font Support"]=>
    bool(false)
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion