CyberHosting

CRON Management not working in 1.8.6

During one of the recent updates, my CRON Management screen stopped working. Regardless of which website I selected, it would not display any of the CRON jobs associated with the website. I just upgraded to 1.8.6, hoping that would fix the issue.

It now displays the CRON jobs, but they're all messed up. It looks like it's filling in all the CRON fields with the output from some error message about mailUtilities.py. Here's a link to a screen shot that demonstrates the issue:

https://cl.ly/41fcdc/Image%25202019-07-13%2520at%25207.13.30%2520PM.png

I also have a similar issue in the control panel for my websites. It displays a long error message in the Bandwidth Usage field:

https://cl.ly/179f7c/Image%25202019-07-13%2520at%25207.16.11%2520PM.png

Comments

  • Hello @bkonia

    First you need to do a force upgrade now.

    Then

    cd /var/spool/cron

    You will see various cron files there, you need to make sure that each cron file is owned by its respective user.

    For any website you can find its user when you launch the website and click 'Setup SSH Access', there you can see that user. Cron file will also have the same name, you can then do

    chown user:user user
  • I am having this same issue.

    Cyberpanel is 1.8.6, I just now ran upgrade to be sure
    LSWS is version 5.3.5 build 9

    The cron condition will not save if I am using WGET (wget -q -O - http://yourdomain.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1
    )

    but if I use direct PHP it works: php /home/yourdomain.com/public_html/wp-cron.php
  • edited July 15
    First, please explain what you mean by a "force upgrade". I upgraded by running the upgrade.py script. Do I need to do something different?

    Second, all the cron files were owned by root. I changed the ownership of each file to its user, but the issue persists. Also, I still have the issue with the Bandwidth Usage field displaying an error message.
  • @engageaustin

    I will take care of this, will let you know once fixed.

    @bkonia

    You can follow this guide ->https://cyberpanel.net/docs/upgrading-cyberpanel/

    Always remember to remove old upgrade.py.
  • As I explained, I already ran the upgrade.py script, so referring me back to the instructions to run the same script is not helpful. And yes, I followed ALL the steps, including deleting the old upgrade.py. I've confirmed in Version Management that it was updated to 1.8.6.

    Once again, after running the upgrade and fixing the cron permissions, the issues persist. What now?
  • edited July 17
    I upgraded to 1.8.7 and that fixed some of the issues. However, when I try to add a new cron job, I get the following error:

    Unable to add/save Cron. Error message: 'cronCommand'

    I've confirmed that the cron file is owned by the user associated with the website.

    I also have a similar problem when trying to add firewall rules. It says:

    Error message: 'ruleIP'

    And yes, I tried clearing my browser cache, even tried a different browser. Didn't help.
  • @bkonia

    Clear your browser cache, so that you get update java script files. This will solve other issues you mentioned.
  • As I mentioned, I already cleared the browser cache and even tried using a different browser that had never before been used to access CyberPanel.
  • If you're looking for a simpler cron job solution, you might consider webcron services which will load a specific URL at a given time.
  • Anyone still have cron issues? Because I've resolved all the issues with cron jobs, if there is still any, let me know.
  • Hello, how often bandwidth cron is running? i have 20 hours since install and there no bandwidth usage
  • @dyrer

    Check using cat /etc/crontab

    Also check owner of this file ls -la /etc/crontab it should be root.

    You can change to root, if not already chown root:root /etc/crontab
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!