CyberHosting

Wordpress Installer not working

I have just installed Cyberpanel onto Centos7 as a test run.

The install seems to have worked OK.

I created a User and a website. I pointed the DNS to the IP and that all seems successful.

When I try to run the Wordpress + LSCache installer I get an error. "Installation failed. Error message: Data supplied is not accepted."

I have removed the index file and tried a subfolder but keep getting the same error.

Can anyone assist?

Thanks

Comments

  • Sorry just to confirm your answer. There was a bug? It is now fixed? How do I implement the fix?

    Thanks

  • So i managed to update Cyberpanel to 1.8.7. Started the wordpress install. It started, which is better than previous, then it failed.

    Error: Installation failed. Error message: 'int' object is not iterable [404]
  • Provider: Vultr,

    Virtualization Type: KVM

    System: CentOS 7 x64

    Installation option: since during the installation.
    there will be few option to choose,so please provide it as well.

    OLS or Enterprise?
    OLS

    Installing from official server or mirror server?
    official

    Replace JS/CSS files to JS Delivr?
    YES

    Install Memcached extension for PHP?
    YES

    Install LiteSpeed Memcached?
    YES

    Install Memcached?
    YES

    Install Redis extension for PHP?
    YES

    Install Redis?
    YES


    Problem:
    I believe all of the above information is correct but is there an info page that can confirm it?

    Started the wordpress install. It started says started for about 2 seconds then it fails with
    Error: Installation failed. Error message: 'int' object is not iterable [404]
  • Replace JS/CSS files to JS Delivr?
    YES

    Install Memcached extension for PHP?
    YES

    Install LiteSpeed Memcached?
    YES

    Install Memcached?
    YES

    Install Redis extension for PHP?
    YES

    Install Redis?
    YES
    Try setting them to NO, I guess you are getting cached files.
  • How can I disable them? Is possible to clear the cache instead of disabling the cache?
  • @qtwrk

    How can we get original cache files or can you make them available via JS Delivr? Just need to make sure that updates files are on JS Delivr.
  • @qtwrk

    How can we get original cache files or can you make them available via JS Delivr? Just need to make sure that updates files are on JS Delivr.

    which files you meant ?
  • @qtwrk

    All the JS files, do you replace all files on JS Delivr, or only few of them?
  • @qtwrk

    All the JS files, do you replace all files on JS Delivr, or only few of them?

    most of them , but I think some of them wasn't replaced.
  •   1. Install CyberPanel with OpenLiteSpeed.

    2. Install Cyberpanel with LiteSpeed Enterprise.

    3. Exit.


    Please enter the number[1-3]: 1


    Install minimal service for CyberPanel? This will skip PowerDNS, Postfix and Pure-FTPd.
    Minimal installation [y/N]: n

    Do you wish to install Postfix?
    Postfix installation [Y/n]: y

    Do you wish to install PowerDNS?
    PowerDNS installation [Y/n]: y

    Do you wish to install Pure-FTPd?
    Pure-FTPd installation [Y/n]: y

    Please choose to use default admin password 1234567, randomly generate one (recommended) or specify the admin password?
    Choose [d]fault, [r]andom or [s]et password: [d/r/s] d

    Admin password will be set as 1234567


    Replace JS/CSS files to JS Delivr?
    This may improve panel loading speed in Asia Pacific region...
    Please select [y/N]: y

    Install Memcached extension for PHP?
    Please select [y/N]: y

    Install LiteSpeed Memcached?
    Please select [y/N]: y

    Install Redis extension for PHP?
    Please select [y/N]: y

    Install Redis?
    Please select [y/N]: y

    on Vultr , but I don't see any issue with WP installer.

  • I will try a fresh install. However could it be related to me changing the Sql root password? I tried to access phpmyadmin & couldn't login so changed the password. What should the password be set to? Root or Admin password? Or something else?
  • Hi,

    That is possible , installer will require mysql root password to set up database and create user for WP.

    If you changed it without notify cyberpanel , it will break many functions.
  • So what should the password be? Is it the same as the sever root or the cyberpanel admin or something else altogether?
  • edited July 19
    @redmondsau

    Correct, please read -> https://forums.cyberpanel.net/discussion/171/some-donts-after-installing-cyberpanel

    In short:

    /etc/cyberpanel/mysqlPassword
    /usr/local/CyberCP/CyberCP/settings.py

    These files need to have correct and updated MySQL root password.
  • OK. So overcome 1 issue only to encounter 2 more.

    I could not reset my password via ssh even after running the python script.

    I reinstalled the OS, reinstalled Cyberpanel.
    I did a test install of wordpress and it worked OK. Except the username/password that I used for the Wordpress account don't work.

    I tried to connect to phpMysql and cannot login to that either. I checked the password as stored in both of the files above and tried to sue them. Still no luck.

    I requested a password reset from wordpress (email) and did not recieve an email.

    So it seems as though the Wordpress installer is not using the password that is submitted during setup.

    It seems as though MySQL is using a different password to that stored in the setup files.

    It seems as though the server cannot send emails.

    Regards
    Raoul
  • I got the same issue and I've solved it.
    Site Name(WordPress) can only included words on the WordPress installation process of CyberPanel.
    That's what the ridiculous issue is...
  • I just installed it with name "wordpress"...
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!