1.8.7 — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

1.8.7

edited July 2019 in Bug Report
fresh install centos 7.6.1810
kvm vps
yum -y update
cyberpanel with OLS
minimal

yum -y install opendkim


Issues:
1) Remote Backups(Transfer) from another 1.8.7 host does not work perfect, when waiting for restore to complete, it does not come up complete msg but ends with "No Such Log Found" in Red. But it is success.

2) For every remote backup (transfer), the database password has to change (Database > List Database > Changepassword). In 1.8.7 does not work:
"Cannot change password for ***, Error message: Databases matching query does not exist."
only can manually change inside phpmyadmin.

3) After sometime the webpanel cannot access:
{"errorMessage": "Session reuse detected, IPAddress logged.", "error_message": "Session reuse detected, IPAddress logged."}


4) SSH cannot change port.

5) Scheduled Remote Backups (recipient is 1.8.4) not working.

Comments

  • Thanks, I will reproduce and release a fix.
  • FYI. Can you explain this point in details
    2) For every remote backup (transfer), the database password has to change (Database > List Database > Changepassword). In 1.8.7 does not work:
    "Cannot change password for ***, Error message: Databases matching query does not exist."
    only can manually change inside phpmyadmin.
    ?
  • I think 2 and 5 I can not reproduce, because i sent remote backups to a server and restored them. Everything went smoothly and sites are working fine.

    For your point 5. Recipient need not be CyberPanel at all, just a server with SSH access. But still I need to check CyberPanel -> CyberPanel transfer.
  • 1. It should be fixed, backup directory was being removed so status can't be read.

    2. Can't reproduce on v1.8.7, works on my end until you provide more details.

    3. Are you on IPv6?

    4. Fixed.

    5. Better upgrade on both ends.

    I just pushed the package, you may want to force upgrade even if you are on v1.8.7.
  • edited July 2019
    > @CyberPanel said:
    > 1. It should be fixed, backup directory was being removed so status can't be read.
    >
    > 2. Can't reproduce on v1.8.7, works on my end until you provide more details.
    >
    > 3. Are you on IPv6?
    >
    > 4. Fixed.
    >
    > 5. Better upgrade on both ends.
    >
    > I just pushed the package, you may want to force upgrade even if you are on v1.8.7.

    Thanks. I will check again and update

    2. I will update with pictures.

    3. This happened when my IP was changed (LAN to WiFi). Had to clear browser cache to see login page. IPv4.

    4. Thanks.

    5. Will do so and update.
  • edited July 2019
    > @CyberPanel said:
    > FYI. Can you explain this point in details 2) For every remote backup (transfer), the database password has to change (Database > List Database > Changepassword). In 1.8.7 does not work:
    > "Cannot change password for ***, Error message: Databases matching query does not exist."
    > only can manually change inside phpmyadmin.
    >
    > ?

    https://i.ibb.co/4RDB1Vz/Screenshot-20190718-183405.jpg
  • @cybertech

    How can I reproduce this issue?
  • edited July 2019
    > @CyberPanel said:
    > @cybertech
    >
    > How can I reproduce this issue?

    This is the database page where I select my database and change password. It's unable to since 1.8.6

    This database is from a site restore (create backup in remote host using 1.8.4, scp transfer to local host , restore backup)


    Current workaround is to access phpmyadmin and change password for this database user.
  • @cybertech

    Can you upgrade your server to v1.8.7, regenerate backup, scp to server and restore, is it same?
  • @cybertech

    Can you upgrade your server to v1.8.7, regenerate backup, scp to server and restore, is it same?

    I just tried this on a latest v1.8.7 fresh install from 30mins ago:

    - Create New Website
    - Create New Database and set new password
    - Change password for above new database

    Same error as attached picture.
  • @cybertech

    Still can't reproduce on my end, seem something wrong in your database name. Kindly reveal database name for us.
  • @cybertech

    Still can't reproduce on my end, seem something wrong in your database name. Kindly reveal database name for us.

    when i create a website example cybertech.com

    the database is in this prefix: cybe_****

    so i have created 2 new database and username as below:

    cybe_tech - cybe_user
    cybe_database - cybe_techuser

    both cannot change password with same error.


    "Cannot change password for cybe_techuser, Error message: Databases matching query does not exist."
  • if still cannot reproduce, dont mind let me know how you test.
  • @cybertech

    I will try to reproduce and get back.
  • There was a bug, fixed and pushed.
  • @CyberPanel thanks for the work. Just tested everything except scheduled remote backups, and all work well.

    I get this error when trying to (re)add a freshly install 1.8.7.

    https://i.ibb.co/VDnzxtd/Screenshot-20190724-192032.jpg
  • edited July 2019
    cybertech said:

    @CyberPanel thanks for the work. Just tested everything except scheduled remote backups, and all work well.

    I get this error when trying to (re)add a freshly install 1.8.7.

    https://i.ibb.co/VDnzxtd/Screenshot-20190724-192032.jpg

    @CyberPanel now able to add backup destination after i change the destination 1.8.7 panel from default password to new password.

    Will report back whether daily autmated backup works.
  • @cybertech

    You can manually run backups at anytime using this command python /usr/local/CyberCP/plogical/backupSchedule.py

    I just fixed a minor issue with cron settings for scheduled backups. However you can manually edit cron to run this command whenever you need. You can set cron command in /etc/crontab
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!