CyberHosting

Email Not working in 1.8.7

Hello, These need a hot fix/quick fix

1. Email service is not working after upgrading from v1.8.6 to v1.8.7. Authentication error message.

2. This happens on clean installs as well. When backups are restored the issue happens. However, when new emails are created on a clean install, the issue does not exist

Comments

  • edited July 2019
    NiiYankee said:

    Hello, These need a hot fix/quick fix

    1. Email service is not working after upgrading from v1.8.6 to v1.8.7. Authentication error message.

    2. This happens on clean installs as well. When backups are restored the issue happens. However, when new emails are created on a clean install, the issue does not exist

    This is because they switched the authentication from 1.8.5 to 1.8.6 to both MD5 and CRYPT (this was a bug), and from 1.8.6 to 1.8.7 to exclusively CRYPT. The bug was that they migrated the old emails in 1.8.6 to MD5 when they should have been migrated to CRYPT. As a result, when these MD5 emails were then migrated to CRYPT in 1.8.7, they were double encrypted and thus rendered unreadable. As least, that was my experience. So unless you have a pre-1.8.6 backup of your site data when email passwords were stored in non-encrypted plain text form, you may end up having to reset all your emails. Sorry about that.
  • edited July 2019
    I can not create threads in this forum, for some reason, so I will post it here.

    I upgraded from 1.8.5 to 1.8.7 and now I can not send emails, on wordpress the error is that maybe the mail() function is not active, and on rainloop, the send button turns red and says Can't send email.

    When I use, on the console, sendmail like:

    sendmail -t [email protected]
    From: Test
    Subject: Test
    test
    .

    I get the email on my inbox. I haven't changed any settings or modified in any way the php configuration.
    On the mail.err log file is this error:
    server postfix/sendmail[3477]: fatal: /etc/postfix/dynamicmaps.cf: file open failed: Permission denied

    I have checked the permission for this file and they are:
    -rw-r----- 1 root postfix 100 Jan 28 16:20 dynamicmaps.cf

    I don't know that else to do and where to look to solve this problem.

  • @Hifihedgehog

    Thanks for helping out the people, really appreciated.

    @ElmerSH

    chmod 644 /etc/postfix/dynamicmaps.cf
  • @CyberPanel I tried that and the same error is showing on the mail.err log file. I also tried changing the owner to root:root and still the same.
  • @ElmerSH

    did you restart postfix after updating permissions?
  • I didn't. Now it is working for my WordPress sites, but not on rainloop. Still the same error on the interface, but there is no error on mail.err and on the syslog file I found this:


    Jul 21 20:53:05 server postfix/smtpd[28503]: warning: cannot get RSA certificate from file "/etc/pki/dovecot/certs/dovecot.pem": disabling TLS support

    Jul 21 20:53:05 server postfix/smtpd[28503]: warning: TLS library problem: error:02001002:system library:fopen:No such file or directory:../crypto/bio/bss_file.c:290:fopen('/etc/pki/dovecot/certs/dovecot.pem','r'):

    Jul 21 20:53:05 server postfix/smtpd[28503]: warning: TLS library problem: error:20074002:BIO routines:file_ctrl:system lib:../crypto/bio/bss_file.c:292:
    Jul 21 20:53:05 server postfix/smtpd[28503]: warning: TLS library problem: error:140DC002:SSL routines:use_certificate_chain_file:system lib:../ssl/ssl_rsa.c:615:
  • @ElmerSH

    Try to issue mail server ssl Dashboard -> SSL -> Mailserver SSL
  • Thanks for your help @CyberPanel, I did that and it worked again.
    By the way, there are more issues win 1.8.7, Docker for example. I tried installing it from cyberpanel, then searched for an image (discourse)
    When I click in the dropdown menu to select a tag, it shows nothing and a popup notice shows with this text:

    Unable to complete request
    Data supplied is not accepted.

    First time trying Docker images.
  • @ElmerSH

    Fixed the docker issue last night and pushed, you can upgrade.
  • If are not receiving emails like I was, use the line above from CyberPanel. Viewing this from a full-stack perspective with multiple dev hats, I imagine it impacted most if not all upgrading users:

    chmod 644 /etc/postfix/dynamicmaps.cf
  • edited August 2019
    The issue still exists currently of not being able to *receive* email after upgrading. I had to run the command above again, "644 /etc/postfix/dynamicmaps.cf", once after upgrading from 1.8.8 to 1.8.9, and again from 1.8.9 to 1.9.0.
  • @Hifihedgehog

    I added this as part of upgrade process. It should be fine now.
  • Type your comment> @CyberPanel said:
    > @ElmerSH
    >
    > Try to issue mail server ssl Dashboard -> SSL -> Mailserver SSL

    this fixed my problem for both in and out emails. thank you
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!