CyberHosting

Cyberpanel is can't be installed on Alibaba Cloud

edited July 2019 in Bug Report
Hi,

OLS or Enterprise:
OLS

Installing from official server or mirror server:
Yes

Replace JS/CSS files to JS Deliver:
yes

Install Memcached extension for PHP?
no

Install LiteSpeed Memcached?
no

Install Memcached?
no

Install Redis extension for PHP?
yes

Install Redis?
yes

Problem:

I can't install Cyberpanel on Alibaba cloud. I have 2CPU and 4GB Ram server.
Operation Systems I tried to install Cyberpanel: Centos 7.6 - Ubuntu 18.04



[12-08-36-Wed-Jul-2019] #########################################################################

[12-08-36-Wed-Jul-2019] Trying to install tldextract, trying again, try number: 20

[12-08-36-Wed-Jul-2019] #########################################################################

Collecting bcrypt
Downloading http://mirrors.cloud.aliyuncs.com/pypi/packages/50/d8/95f7cb04344033bf9d1a12c5a7969a15999b6a710fbe1969c517333d9a62/bcrypt-3.1.6-cp27-cp27mu-manylinux1_x86_64.whl (59kB)
100% |████████████████████████████████| 61kB 309kB/s
Collecting cffi>=1.1 (from bcrypt)
Downloading http://mirrors.cloud.aliyuncs.com/pypi/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl (407kB)
100% |████████████████████████████████| 409kB 60.7MB/s
Requirement already satisfied (use --upgrade to upgrade): six>=1.4.1 in /usr/lib64/python2.7/site-packages (from bcrypt)
Collecting pycparser (from cffi>=1.1->bcrypt)
Downloading http://mirrors.cloud.aliyuncs.com/pypi/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz (158kB)
100% |████████████████████████████████| 163kB 64.9MB/s
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "", line 1, in
File "/tmp/pip-build-ZXlMpO/pycparser/setup.py", line 65, in
cmdclass={'install': install, 'sdist': sdist},
File "/usr/lib64/python2.7/distutils/core.py", line 112, in setup
_setup_distribution = dist = klass(attrs)
File "/usr/lib/python2.7/site-packages/setuptools/dist.py", line 269, in __init__
_Distribution.__init__(self,attrs)
File "/usr/lib64/python2.7/distutils/dist.py", line 287, in __init__
self.finalize_options()
File "/usr/lib/python2.7/site-packages/setuptools/dist.py", line 302, in finalize_options
ep.load()(self, ep.name, value)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2341, in load
return self.resolve()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2351, in resolve
raise ImportError(str(exc))
ImportError: 'module' object has no attribute 'check_specifier'

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-ZXlMpO/pycparser/
You are using pip version 8.1.2, however version 19.2.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Comments

Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!