SSL Cert not installed on website (Cloudflare nameservers). Works on cPanel brand. — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

SSL Cert not installed on website (Cloudflare nameservers). Works on cPanel brand.

Provider: Me

Dedicated Server 2x2680v2 256GB RAM 500GB SSD

Ubuntu 18.04.2 LTS (Fresh install, update, upgrade)

OLS or Enterprise? OLS
CyberPanel 1.8.8 Fresh Install (not upgrade)

The following info is from my memory. Is there a log I can check?

Installing from official server or mirror server? official

Replace JS/CSS files to JS Delivr? no

Install Memcached extension for PHP? Yes

Install LiteSpeed Memcached? yes

Install Memcached? no

Install Redis extension for PHP? yes

Install Redis? yes


Problem:

Unable to obtain Let's Encrypt SSL Cert for domain where Cloudflare provides authoritative nameserver services. Neither did CyberPanel create a self-signed cert as docs stated would happen if certbot failed. Error message: 283 Failed to obtain SSL for domain. [issueSSLForDomain] [404]

Certbot seems to do fine with cPanel brand hosted websites running LSWS Enterprise under same circumstances so suspect this is fixable.

Comments

  • Can you try to create site without SSL, then use Manage SSL to issue the SSL? It is possible it might have hit Lets Encrypt weekly limit?
  • Site has been "running" without SSL all along. Subject to other bug reports that is. So running means serving the two sample pages since we cannot add new blog posts and pages. Serving them from cache on a world-class web server. Hello World!

    Attempting SSL cert after-the-fact received the same error. Weekly certbot limit is 5 if memory serves me correctly and this is new domain so limit is likely not the problem. Certainly at limit by now because kept pushing the button like a monkey. Mindful that one of the definitions of insanity is doing the same thing and expecting a different result. Hello World!

    This is a test server for now so we can experiment as needed. If creating an A record for a subdomain gets us a fresh 5 count we'll give that a shot. Will it?
  • Site has been "running" without SSL all along. Subject to other bug reports that is. So running means serving the two sample pages since we cannot add new blog posts and pages. Serving them from cache on a world-class web server. Hello World!

    Attempting SSL cert after-the-fact received the same error. Weekly certbot limit is 5 if memory serves me correctly and this is new domain so limit is likely not the problem. Certainly at limit by now because kept pushing the button like a monkey. Mindful that one of the definitions of insanity is doing the same thing and expecting a different result. Hello World!

    This is a test server for now so we can experiment as needed. If creating an A record for a subdomain gets us a fresh 5 count we'll give that a shot. Will it?
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!