CyberHosting

Suddenly Power DNS and PureFTPD Stopped

Hi, Suddenly my clients server's Suddenly Power DNS and PureFTPD Stopped working. After clicking on restart and start button it does nothing.
I was running cyberpanel v1.8.0. And then an update might solve the problem. So i upgraded and its still not working. What should i do ?

Comments

  • Same here!

    CentOS 7, Cyberpanel 1.9

    I updated CentOS and Cyberpanel, but it's still not working.
    Server status > Services status page indicates: OpenLiteSpeed - Running, MariaDB - Running, PowerDNS - Stopped (with green Play icon) and PureFTPd - Stopped (with orange Pause icon).
  • I'm using this code as the solution to the same problem I have;

    pdns_server --config-dir=/etc/pdns/

    but after a while the power dns shuts down again.
  • Just been discussing this on discord. try chmod 0755 your pdns.conf see it restarts.

    Needs further investigation but it appeared to work.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • Update: If you have recently updated or have had yum / apt update pdns then you may now discover that pdns is running under its own user pdns

    change the owner of the pdns.conf file to pdns and it should start/restart the service.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • Thanks, hennaboy! It's working!
  • how do i do that ? can you elaborate. Actually I am very new to all this vps server management.
  • I'm using this code as the solution to the same problem I have;

    pdns_server --config-dir=/etc/pdns/

    but after a while the power dns shuts down again.

    I run this command in my ssh command line interface and power dns and pure ftp started .
    Dont know how much time this will remain solved.
    Thanks for the help.
  • I'm using this code as the solution to the same problem I have;

    pdns_server --config-dir=/etc/pdns/

    but after a while the power dns shuts down again.

    Thanks Man
    https://prnt.sc/p963x6
  • hennaboy said:

    Just been discussing this on discord. try chmod 0755 your pdns.conf see it restarts.

    Needs further investigation but it appeared to work.

    Thank You :)
    https://prnt.sc/p963x6
  • cotlasweb said:

    how do i do that ? can you elaborate. Actually I am very new to all this vps server management.

    chown pdns:pdns /etc/pdns/pdns.conf
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • I'm using this code as the solution to the same problem I have;

    pdns_server --config-dir=/etc/pdns/

    but after a while the power dns shuts down again.

    You are right, The power dns shuts it down after 2 days. I dont know what to do. Trying to run hennaboy's command. Lets see what happns ?
  • hennaboy said:

    cotlasweb said:

    how do i do that ? can you elaborate. Actually I am very new to all this vps server management.

    chown pdns:pdns /etc/pdns/pdns.conf
    This doesnt help, the problem arises again. Today i run this command "chown pdns:pdns /etc/pdns/pdns.conf" again but it doesnt solve the problem , so i tried this one and it started again "pdns_server --config-dir=/etc/pdns/"

    But when i run this command, the ssh window freezes, I have to close and re start ssh client to login. This command does not complete but it solves the problem, and the problem arises again in 2 or 3 days.

    Can anyone help me with this ?
  • Confirm costlasweb! Same problem here! Command "chown pdns:pdns /etc/pdns/pdns.conf" doesn't work anymore.
  • I think i should move to another panel like centos web panel. these problems are irritating and also we loose our reputation in front of clients.
  • It should be like
    [[email protected] pdns]# ls -la
    total 44
    drwxr-xr-x. 2 root root 4096 Oct 4 02:00 .
    drwxr-xr-x. 89 root root 4096 Sep 18 12:50 ..
    -rw-r--r--. 1 root root 15714 Aug 8 15:06 pdns.conf
  • Working now! I have changed pdns.conf permissions:
    chmod 666 /etc/pdns/pdns.conf
  • edited October 2019
    Yeah for anyone else if you "stat" the file it should show the exact number like the example with 644 provided by cyberpanel above. Mine was actually set to 600 and was working and tested with 666 to like above and it also works. So 600,644,666 should work.

    CentOS
    chown root:root /etc/pdns/pdns.conf
    chmod 644 /etc/pdns/pdns.conf

    Ubuntu path is slightly different.
    chown root:root /etc/powerdns/pdns.conf
    chmod 644 /etc/powerdns/pdns.conf

    Then use systemctl to start/stop/restart

    systemctl start pdns
    systemctl restart pdns
    systemctl status pdns

    Example:
    Centos
    [[email protected]:~]# stat /etc/pdns/pdns.conf
    File: ‘/etc/pdns/pdns.conf’
    Size: 15680 Blocks: 32 IO Block: 4096 regular file
    Device: fd01h/64769d Inode: 386219 Links: 1
    Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
    Access: 2019-09-07 10:32:58.445839561 -0400
    Modify: 2019-08-20 23:25:08.501273032 -0400
    Change: 2019-10-04 09:11:49.169724817 -0400
    Birth: -
    [[email protected]:~]#


    Ubuntu
    [email protected]:/etc/powerdns# stat /etc/powerdns/pdns.conf
    File: /etc/powerdns/pdns.conf
    Size: 15714 Blocks: 32 IO Block: 4096 regular file
    Device: 801h/2049d Inode: 517909 Links: 1
    Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
    Access: 2019-05-11 07:08:37.954140041 -0400
    Modify: 2019-05-11 07:08:37.958140041 -0400
    Change: 2019-10-04 09:14:21.034326231 -0400
    Birth: -
    [email protected]:/etc/powerdns#
  • cotlasweb said:

    hennaboy said:

    cotlasweb said:

    how do i do that ? can you elaborate. Actually I am very new to all this vps server management.

    chown pdns:pdns /etc/pdns/pdns.conf
    This doesnt help, the problem arises again. Today i run this command "chown pdns:pdns /etc/pdns/pdns.conf" again but it doesnt solve the problem , so i tried this one and it started again "pdns_server --config-dir=/etc/pdns/"

    But when i run this command, the ssh window freezes, I have to close and re start ssh client to login. This command does not complete but it solves the problem, and the problem arises again in 2 or 3 days.

    Can anyone help me with this ?
    If an issue arises again after a few days then you probably have more than one issue.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • yeah, this was most likely due to running it manually as a command "pdns_server --config-dir=/etc/pdns/" which got killed vs in daemon mode via systemctl like "systemctl restart pdns" how it's normally managed.

  • edited October 2019
    thanks everyone, I have solved it. I did it like this ......

    [[email protected] ~]# cd /etc/pdns
    [[email protected] pdns]# ls -la
    total 44
    drwxr-xr-x 2 root root 4096 Oct 4 02:00 .
    drwxr-xr-x. 83 root root 4096 Oct 4 11:38 ..
    -rw------- 1 pdns pdns 15680 Jun 9 20:00 pdns.conf
    -rw------- 1 root root 17069 Aug 28 19:31 pdns.conf.rpmnew
    [[email protected] pdns]# chmod 666 /etc/pdns/pdns.conf
    [[email protected] pdns]# ls -la
    total 44
    drwxr-xr-x 2 root root 4096 Oct 4 02:00 .
    drwxr-xr-x. 83 root root 4096 Oct 4 11:38 ..
    -rw-rw-rw- 1 pdns pdns 15680 Jun 9 20:00 pdns.conf
    -rw------- 1 root root 17069 Aug 28 19:31 pdns.conf.rpmnew
    [[email protected] pdns]# chown root:root /etc/pdns/pdns.conf
    [[email protected] pdns]# ls -la
    total 44
    drwxr-xr-x 2 root root 4096 Oct 4 02:00 .
    drwxr-xr-x. 83 root root 4096 Oct 4 11:38 ..
    -rw-rw-rw- 1 root root 15680 Jun 9 20:00 pdns.conf
    -rw------- 1 root root 17069 Aug 28 19:31 pdns.conf.rpmnew
    [[email protected] pdns]# systemctl start pdns
    [[email protected] pdns]# systemctl restart pdns
    [[email protected] pdns]# systemctl status pdns
    ● pdns.service - PowerDNS Authoritative Server
    Loaded: loaded (/usr/lib/systemd/system/pdns.service; enabled; vendor preset: disabled)
    Active: active (running) since Sun 2019-10-06 10:24:14 CEST; 13s ago
    Docs: man:pdns_server(1)
    man:pdns_control(1)
    https://doc.powerdns.com
    Main PID: 18687 (pdns_server)
    CGroup: /system.slice/pdns.service
    └─18687 /usr/sbin/pdns_server --guardian=no --daemon=no --disable-...

    Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: TCP server bo...
    Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: TCPv6 server ...
    Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: PowerDNS Auth...
    Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: Using 64-bits...
    Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: PowerDNS come...
    Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: Polled securi...
    Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: Creating back...
    Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: About to crea...
    Oct 06 10:24:14 vmi241085.contaboserver.net systemd[1]: Started PowerDNS Auth...
    Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: Done launchin...
    Hint: Some lines were ellipsized, use -l to show in full.
    [[email protected] pdns]#
  • Had similar problem as in when I updated and moved aws snapshot to new instance. I checked `server status' and all 4 not showing with `Could not connect to server. Please refresh this page' error at bottom. After looking round, reading this and others to no avail.
    It hit me `Hostname SSL' > sure enough when I renewed the hostname ssl > all worked on refresh (3 clicks - 2 minutes) Hope this helps someone...
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!