CyberHosting

Unknown mail transport error / queue active

Hello,
incoming mails are in queue.
mail log:
postfix/qmgr[5435]: 3B16946AE69: from=, size=4146, nrcpt=1 (queue active)

mailq
AEC2A46AE6E 12186 Tue Oct 1 00:36:54 ssssssss@ssssssssss.com
(unknown mail transport error)
zzzz@zzzzz.com

postfix flush

postfix: Postfix is running with backwards-compatible default settings
postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_sender_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_client_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_helo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_sender_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_client_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_helo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/main.cf: undefined parameter: virtual_mailbox_limit_maps
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_extended=yes

Please help

Comments

  • I just happened this, I still haven't found the real cause (100% effective, but I've managed to make it work) @franko

    1º remove spamassing
    - ssh: yum remove spamassing

    2º remove residuals
    rm -Rf /etc/mail/spamassassin
    (i use nano, you cand use vi or vim) nano /etc/postfix/master.cf

    remplace
    smtp inet n - n - - smtpd -o content_filter=spamassassin

    to
    smtp inet n - n - - smtpd

    and remove last line
    spamassassin unix - n n - - pipe flags=R user=spamd argv=/usr/bin/spamc -e /usr/sbin/sendmail -oi -f ${sender} ${recipient}


    3º add permissions dovecot
    nano /etc/dovecot/dovecot.conf and and this lines at the end of the document

    service stats {
    unix_listener stats-reader {
    user = vmail
    group = vmail
    mode = 0660
    }

    unix_listener stats-writer {
    user = vmail
    group = vmail
    mode = 0660
    }
    }


    4º restart services
    systemctl restart dovecot
    systemctl restart postfix

    5º remove queue (The queue was not sent, I had to eliminate it)
    postsuper -d ALL
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion