CyberHosting

Error upgarde cyberpanel to version 1.9.1

I follow step by step
https://forums.cyberpanel.net/discussion/85/how-to-manually-upgrade-downgrade-cyberpanel

i run command line
[[email protected] CyberCP]# python manage.py makemigrations

Traceback (most recent call last):
File "manage.py", line 22, in
execute_from_command_line(sys.argv)
File "/usr/lib64/python2.7/site-packages/django/core/management/__init__.py", line 363, in execute_from_command_line
utility.execute()
File "/usr/lib64/python2.7/site-packages/django/core/management/__init__.py", line 355, in execute
self.fetch_command(subcommand).run_from_argv(self.argv)
File "/usr/lib64/python2.7/site-packages/django/core/management/base.py", line 283, in run_from_argv
self.execute(*args, **cmd_options)
File "/usr/lib64/python2.7/site-packages/django/core/management/base.py", line 327, in execute
self.check()
File "/usr/lib64/python2.7/site-packages/django/core/management/base.py", line 359, in check
include_deployment_checks=include_deployment_checks,
File "/usr/lib64/python2.7/site-packages/django/core/management/base.py", line 346, in _run_checks
return checks.run_checks(**kwargs)
File "/usr/lib64/python2.7/site-packages/django/core/checks/registry.py", line 81, in run_checks
new_errors = check(app_configs=app_configs)
File "/usr/lib64/python2.7/site-packages/django/core/checks/urls.py", line 16, in check_url_config
return check_resolver(resolver)
File "/usr/lib64/python2.7/site-packages/django/core/checks/urls.py", line 26, in check_resolver
return check_method()
File "/usr/lib64/python2.7/site-packages/django/urls/resolvers.py", line 254, in check
for pattern in self.url_patterns:
File "/usr/lib64/python2.7/site-packages/django/utils/functional.py", line 35, in __get__
res = instance.__dict__[self.name] = self.func(instance)
File "/usr/lib64/python2.7/site-packages/django/urls/resolvers.py", line 405, in url_patterns
patterns = getattr(self.urlconf_module, "urlpatterns", self.urlconf_module)
File "/usr/lib64/python2.7/site-packages/django/utils/functional.py", line 35, in __get__
res = instance.__dict__[self.name] = self.func(instance)
File "/usr/lib64/python2.7/site-packages/django/urls/resolvers.py", line 398, in urlconf_module
return import_module(self.urlconf_name)
File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "/usr/local/CyberCP/CyberCP/urls.py", line 46, in
url(r'^IncrementalBackups/', include('IncBackups.urls')),
File "/usr/lib64/python2.7/site-packages/django/conf/urls/__init__.py", line 5 0, in include
urlconf_module = import_module(urlconf_module)
File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "/usr/local/CyberCP/IncBackups/urls.py", line 2, in
import views
File "/usr/local/CyberCP/IncBackups/views.py", line 13, in
from .models import IncJob, BackupJob, JobSites
File "/usr/local/CyberCP/IncBackups/models.py", line 7, in
class IncJob(models.Model):
File "/usr/lib64/python2.7/site-packages/django/db/models/base.py", line 118, in __new__
"INSTALLED_APPS." % (module, name)
RuntimeError: Model class IncBackups.models.IncJob doesn't declare an explicit a

Please help me early ! thanks
Tagged:
Tagged:

Comments

  • 503 Service Unavailable, Access to cyberpanel home page
    Bellow show message upgade

    This server has installed CyberPanel.
    Visit https://www.cyberpanel.net
    Forum https://forums.cyberpanel.net
    Log in https://172.96.190.208:8090

    Current Server time : 2019-10-30 17:02:25.
    Current Load average: 0.14, 0.12, 0.19
    Current CPU usage : 1.50878%.
    Current RAM usage : 534/985MB (54.21%).
    Current Disk usage : 11/20GB (54%).
    System uptime : 0 days, 21 hours, 14 minutes.

    Enjoy your accelerated Internet by CyberPanel.

    [[email protected] ~]#
    [[email protected] ~]# wget https://cyberpanel.net/upgrade-ent.py
    --2019-10-30 17:02:29-- https://cyberpanel.net/upgrade-ent.py
    Resolving cyberpanel.net (cyberpanel.net)... 104.27.162.149, 104.27.163.149, 260 6:4700:30::681b:a395, ...
    Connecting to cyberpanel.net (cyberpanel.net)|104.27.162.149|:443... connected.
    HTTP request sent, awaiting response... 301 Moved Permanently
    Location: https://cyberpanel.sh/upgrade-ent.py [following]
    --2019-10-30 17:02:30-- https://cyberpanel.sh/upgrade-ent.py
    Resolving cyberpanel.sh (cyberpanel.sh)... 89.208.248.38
    Connecting to cyberpanel.sh (cyberpanel.sh)|89.208.248.38|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 25916 (25K) [application/octet-stream]
    Saving to: ‘upgrade-ent.py’

    100%[======================================>] 25,916 153KB/s in 0.2s

    2019-10-30 17:02:31 (153 KB/s) - ‘upgrade-ent.py’ saved [25916/25916]

    [[email protected] ~]# python upgrade-ent.py
    Failed to stop gunicorn.socket: Unit gunicorn.socket not loaded.
    Requirement already satisfied (use --upgrade to upgrade): pydns in /usr/lib/pyth on2.7/site-packages
    You are using pip version 8.1.2, however version 19.3.1 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    --2019-10-30 10:02:46-- https://cyberpanel.net/CyberPanelPremium.1.9.1.tar.gz
    Resolving cyberpanel.net (cyberpanel.net)... 104.27.162.149, 104.27.163.149, 260 6:4700:30::681b:a295, ...
    Connecting to cyberpanel.net (cyberpanel.net)|104.27.162.149|:443... connected.
    HTTP request sent, awaiting response... 301 Moved Permanently
    Location: https://cyberpanel.sh/CyberPanelPremium.1.9.1.tar.gz [following]
    --2019-10-30 10:02:47-- https://cyberpanel.sh/CyberPanelPremium.1.9.1.tar.gz
    Resolving cyberpanel.sh (cyberpanel.sh)... 89.208.248.38
    Connecting to cyberpanel.sh (cyberpanel.sh)|89.208.248.38|:443... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2019-10-30 10:02:47 ERROR 404: Not Found.




    [10-02-47-Wed-Oct-2019] ######################################################## #################

    [10-02-47-Wed-Oct-2019] Latest version successfully downloaded!

    [10-02-47-Wed-Oct-2019] ######################################################## #################




    [10-02-47-Wed-Oct-2019] ######################################################## #################

    [10-02-47-Wed-Oct-2019] Backing up settings file.

    [10-02-47-Wed-Oct-2019] ######################################################## #################




    [10-02-47-Wed-Oct-2019] ######################################################## #################

    [10-02-47-Wed-Oct-2019] Settings file backed up.

    [10-02-47-Wed-Oct-2019] ######################################################## #################

    tar (child): CyberPanelPremium.1.9.1.tar.gz: Cannot open: No such file or direct ory
    tar (child): Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now



    [10-02-53-Wed-Oct-2019] ######################################################## #################

    [10-02-53-Wed-Oct-2019] New version successfully extracted!

    [10-02-53-Wed-Oct-2019] ######################################################## #################




    [10-02-53-Wed-Oct-2019] ######################################################## #################

    [10-02-53-Wed-Oct-2019] Restoring settings file!

    [10-02-53-Wed-Oct-2019] ######################################################## #################

    Requirement already satisfied (use --upgrade to upgrade): tldextract in /usr/lib /python2.7/site-packages
    Requirement already satisfied (use --upgrade to upgrade): idna in /usr/lib/pytho n2.7/site-packages (from tldextract)
    Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib /python2.7/site-packages (from tldextract)
    Requirement already satisfied (use --upgrade to upgrade): requests-file>=1.4 in /usr/lib/python2.7/site-packages (from tldextract)
    Requirement already satisfied (use --upgrade to upgrade): requests>=2.1.0 in /us r/lib/python2.7/site-packages (from tldextract)
    Requirement already satisfied (use --upgrade to upgrade): six in /usr/lib/python 2.7/site-packages (from requests-file>=1.4->tldextract)
    Requirement already satisfied (use --upgrade to upgrade): chardet<3.1.0,>=3.0.2 in /usr/lib/python2.7/site-packages (from requests>=2.1.0->tldextract)
    Requirement already satisfied (use --upgrade to upgrade): urllib3<1.23,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests>=2.1.0->tldextract)
    Requirement already satisfied (use --upgrade to upgrade): certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests>=2.1.0->tldextract)
    You are using pip version 8.1.2, however version 19.3.1 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.



    [10-02-53-Wed-Oct-2019] ######################################################## #################

    [10-02-53-Wed-Oct-2019] tldextract successfully installed! [pip]

    [10-02-53-Wed-Oct-2019] ######################################################## #################




    [10-02-53-Wed-Oct-2019] ######################################################## #################

    [10-02-53-Wed-Oct-2019] tldextract successfully installed! [pip]

    [10-02-53-Wed-Oct-2019] ######################################################## #################




    [10-02-53-Wed-Oct-2019] ######################################################## #################

    [10-02-53-Wed-Oct-2019] Setting up virtual enviroment for CyberPanel.

    [10-02-53-Wed-Oct-2019] ######################################################## #################

    Loaded plugins: fastestmirror
    Repository nodesource is listed more than once in the configuration
    Repository nodesource-source is listed more than once in the configuration
    Loading mirror speeds from cached hostfile
    * base: mirror.layeronline.com
    * centosplus: centos.mirror.globo.tech
    * epel: d2lzkl7pfhq30w.cloudfront.net
    * extras: muug.ca
    * updates: muug.ca
    Package libattr-devel-2.4.46-13.el7.x86_64 already installed and latest version
    Package xz-devel-5.2.2-1.el7.x86_64 already installed and latest version
    Package gpgme-devel-1.3.2-5.el7.x86_64 already installed and latest version
    Package 1:mariadb-devel-5.5.64-1.el7.x86_64 is obsoleted by MariaDB-devel-10.1.4 1-1.el7.centos.x86_64 which is already installed
    Package libcurl-devel-7.29.0-54.el7.x86_64 already installed and latest version
    Nothing to do



    [10-02-56-Wed-Oct-2019] ######################################################## #################

    [10-02-56-Wed-Oct-2019] Project dependant modules installed successfully!!

    [10-02-56-Wed-Oct-2019] ######################################################## #################

    Requirement already satisfied (use --upgrade to upgrade): virtualenv in /usr/lib /python2.7/site-packages
    You are using pip version 8.1.2, however version 19.3.1 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.



    [10-02-57-Wed-Oct-2019] ######################################################## #################

    [10-02-57-Wed-Oct-2019] virtualenv installed successfully!

    [10-02-57-Wed-Oct-2019] ######################################################## #################

    No LICENSE.txt / LICENSE found in source
    New python executable in /usr/local/CyberCP/bin/python2
    Also creating executable in /usr/local/CyberCP/bin/python
    Installing setuptools, pip, wheel...
    done.



    [10-03-04-Wed-Oct-2019] ######################################################## #################

    [10-03-04-Wed-Oct-2019] virtualenv setuped successfully!

    [10-03-04-Wed-Oct-2019] ######################################################## #################

    No LICENSE.txt / LICENSE found in source
    New python executable in /usr/local/CyberCP/bin/python2
    Not overwriting existing python script /usr/local/CyberCP/bin/python (you must u se /usr/local/CyberCP/bin/python2)
    Installing setuptools, pip, wheel...
    done.
    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Ple ase upgrade your Python as Python 2.7 won't be maintained after that date. A fut ure version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/relea se-process/#python-2-support
    ERROR: Could not open requirements file: [Errno 2] No such file or directory: '/ usr/local/CyberCP/requirments.txt'



    [10-03-13-Wed-Oct-2019] ######################################################## #################

    [10-03-13-Wed-Oct-2019] Trying to install project dependant modules, trying agai n, try number: 1

    [10-03-13-Wed-Oct-2019] ######################################################## #################

    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Ple ase upgrade your Python as Python 2.7 won't be maintained after that date. A fut ure version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/relea se-process/#python-2-support
    ERROR: Could not open requirements file: [Errno 2] No such file or directory: '/ usr/local/CyberCP/requirments.txt'



    [10-03-14-Wed-Oct-2019] ######################################################## #################

    [10-03-14-Wed-Oct-2019] Trying to install project dependant modules, trying agai n, try number: 2

    [10-03-14-Wed-Oct-2019] ######################################################## #################

    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Ple ase upgrade your Python as Python 2.7 won't be maintained after that date. A fut ure version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/relea se-process/#python-2-support
    ERROR: Could not open requirements file: [Errno 2] No such file or directory: '/ usr/local/CyberCP/requirments.txt'



    [10-03-15-Wed-Oct-2019] ######################################################## #################

    [10-03-15-Wed-Oct-2019] Trying to install project dependant modules, trying agai n, try number: 3

    [10-03-15-Wed-Oct-2019] ######################################################## #################




    [10-03-15-Wed-Oct-2019] ######################################################## #################

    [10-03-15-Wed-Oct-2019] Failed to install project dependant modules! [setupVirtu alEnv]

    [10-03-15-Wed-Oct-2019] ######################################################## #################

    Failed to stop gunicorn.socket: Unit gunicorn.socket not loaded.
    No LICENSE.txt / LICENSE found in source
    New python executable in /usr/local/CyberCP/bin/python2
    Not overwriting existing python script /usr/local/CyberCP/bin/python (you must u se /usr/local/CyberCP/bin/python2)
    Installing setuptools, pip, wheel...
    done.



    [10-03-22-Wed-Oct-2019] ######################################################## #################

    [10-03-22-Wed-Oct-2019] Virtual enviroment for CyberPanel successfully installed .

    [10-03-22-Wed-Oct-2019] ######################################################## #################

    Failed to restart gunicorn.socket: Unit not found.



    [10-03-29-Wed-Oct-2019] ######################################################## #################

    [10-03-29-Wed-Oct-2019] Upgrade Completed.

    [10-03-29-Wed-Oct-2019] ######################################################## #################

    [[email protected] ~]# cd /usr/local/lscp/cyberpanel
    [[email protected] cyberpanel]# chown -R lscpd:lscpd rainloop
    [[email protected] cyberpanel]# systemctl restart lscpd
    [[email protected] cyberpanel]#
  • Hi ALL !
    The error has been fix now.

    pip uninstall urllib3
    yum -y install python-urllib3
    pip install --upgrade requests

    Then : run upgade again

    rm preUpgrade.sh
    wget https://raw.githubusercontent.com/usmannasir/cyberpanel/1.8.0/preUpgrade.sh
    chmod +x preUpgrade.sh
    ./preUpgrade.sh
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion