Cannot create website. Error message: 0,Virtual Host Directory already exists! — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

Cannot create website. Error message: 0,Virtual Host Directory already exists!

edited April 2018 in DNS Server

how to fix this?

Cannot create website. Error message: 0,Virtual Host Directory already exists!

Comments

  • You need to do:

    rm -rf /usr/local/lsws/conf/vhosts/domain.com
    rm -rf /home/domain.com
    
  • how fix it
    Cannot create website. Error message: 0, This domain exists as Alias.
  • how fix it
    Cannot create website. Error message: 0, This domain exists as Alias.

    Did you create the domain as an alias before?
  • no, i don't create alias before,

    first time i use CP v 1.6
    - Create website but error message : Cannot create website. Error message: 0,Virtual Host Directory already exists!
    - Remove website & delete DNS Zone
    - Do : rm -rf /usr/local/lsws/conf/vhosts/domain.com
    rm -rf /home/domain.com
    - Try upgrade to cp v 1.7
    - Then error message : Cannot create website. Error message: 0, This domain exists as Alias.
  • no, i don't create alias before,

    first time i use CP v 1.6
    - Create website but error message : Cannot create website. Error message: 0,Virtual Host Directory already exists!
    - Remove website & delete DNS Zone
    - Do : rm -rf /usr/local/lsws/conf/vhosts/domain.com
    rm -rf /home/domain.com
    - Try upgrade to cp v 1.7
    - Then error message : Cannot create website. Error message: 0, This domain exists as Alias.

    What do you have in : /serverstatus/cyberCPMainLogFile
  • edited July 2018
    log

    [07-06-01-Wed-Jul-2018] Trying to obtain SSL for: domain.com and: www.domain.com
    [07-06-10-Wed-Jul-2018] Successfully obtained SSL for: domain.com and: www.domain.com
  • Use different domain to create a website, it that fails then send me login details via message.

    log

    [07-06-01-Wed-Jul-2018] Trying to obtain SSL for: domain.com and: www.domain.com
    [07-06-10-Wed-Jul-2018] Successfully obtained SSL for: domain.com and: www.domain.com

  • i successfully create different domain.

    then how fix error before
  • i successfully create different domain.

    then how fix error before

    Send your VPS logins via private message.
  • i successfully create different domain.

    then how fix error before

    Send your VPS logins via private message.
    i has same problem, cant create new domain same before,
    before i got massage
    "Cannot create website. Error message: 0,Virtual Host Directory already exists!"

    remove website and dns zone in panel admin
    and i go putty
    rm -rf /usr/local/lsws/conf/vhosts/domain.com
    rm -rf /home/domain.com

    but still error,
    Cannot create website. Error message: 0, This domain exists as Alias.
    can help solved this? :(
  • As a number of people have mentioned, this works:

    rm -rf /usr/local/lsws/conf/vhosts/domain.com
    rm -rf /home/domain.com

    However, you will more than like need to clear the litespeed cache as well. After running the above, also clear the cache by running this:

    /usr/local/lsws/bin/lswsctrl restart
  • when i try to create the web site under panel im getting error massage : Error message: Virtual Host Directory already exists. [404]

    Error image : https://ibb.co/GFrKdhM

    Please help me to fix it.
  • @usmannasir i am not able to delete a website from cyberpanel. After clicking delete it's showing deleted successfully. But its still present in panel. so i can't add it again
  • > @bijay said:
    > @usmannasir i am not able to delete a website from cyberpanel. After clicking delete it's showing deleted successfully. But its still present in panel. so i can't add it again

    Here is the video https://www.awesomescreenshot.com/video/631052?key=bea97c167023bf65c79aa740d73c7773
  • Hello, the same thing happened to me, and I went back to upgrade, and the problem went away, I deleted the domain again and this time I delete it
  • Type your comment> @DesignyourCode said:
    > As a number of people have mentioned, this works:
    >
    > rm -rf /usr/local/lsws/conf/vhosts/domain.com
    > rm -rf /home/domain.com
    >
    > However, you will more than like need to clear the litespeed cache as well. After running the above, also clear the cache by running this:
    >
    > /usr/local/lsws/bin/lswsctrl restart

    this solution working guys, try that
  • huhu i have same problem :(
    Can not creat new website
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!