CyberHosting

PowerDNS does not sync zones from master to slave

Hi,

I've been using Cyberpanel for a couple of weeks and it's been working well.

I am trying to set up a secondary DNS server as described here: https://cyberpanel.net/docs/2-master-slave-powerdns-replication-on-cyberpanel/ Everything was successful and no errors were reported.

However, after following these simple directions, the slave server does not sync with the master. I've created a new site with DNS on the master but after 24 hours there are no zones on the slave. There is nothing when I try "journalctl -f | grep pdns" shows nothing.

What should I do to troubleshoot this? Like I said, everything was successful and there's only a couple of steps so I have no idea what to do now.

Comments

  • So after looking into the configuration files and seeing examples of setting up PowerDNS for replication from master to slave, I can see that Cyberpanel has not set this up at all as it should have. Effectively, PowerDNS server/client doesn't work on Cyberpanel using the web admin. It appears that besides the web server which works well, many of the more advanced features of Cyberpanel are simply broken. PowerDNS replication fails silently though it reports success, email doesn't work, nameservers don't work until extensive reconfiguration is performed on records. It's only been a short time but I'm sure I'd find more if I looked. Time to go back to Virtualmin, where these things just work.
  • benzod said:

    many of the more advanced features of Cyberpanel are simply broken.

    Such as?

Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!