CyberHosting

Email Sending Isnt Working I Cant Add SMTP Host It Gives Timeout

Email sending on rainloop isnt working. I cant add smtp settings. It shows timeout. I posted the log when i click send button: https://paste.ofcode.org/zxughvTP25XahbfEGF6wDv .
Server: Google Cloud (port 25 is blocked by Google i have to use 587 or 465)

Please help me.

Comments

  • Since port 25 is blocked, you cant send any emails to yourself based on the logs you posted (host not found), in theory you can still send emails to others outside of your domain since other ports are not blocked. Other SMTP servers (on the outside) require port 25 to send mails to you. Even if you change your port to - let's say 25250 - the others don't know that they need to access this port to send mails to you.

    https://cloud.google.com/compute/docs/tutorials/sending-mail/
    If you insist on using it to just send mail but not receive, make sure you have set proper spf/rdns records and proper A records for you to be able to send mail.
  • @Numeriku i switched to Yandex Corporate Mail. There's no proper way to use localhost to send mails. Sİnce i changed mx settings to yandex, i cant see new mails on rainloop, it is normal right?
  • @Numeriku yandex has some spam problems. i have to use my server. i created new incoming and outgoing ports which are 2525 or tried as 70, 700 etc on google cloud. all i got "[Errno 113] No route to host"

    how can i fix this?

    there is a "routes" tab on google cloud too but i dont know what should i do here?
  • Its better to use external mail services like mailgun if you just wish to send outgoing mails. I have no time to assist you on this, Hire a sysadmin if you wish to use your local mail but like i said you wont be able to receive mail, only send them.
  • tosunkaya - are you still having this problem?
    I had the same after the host ( Vultr in my case) allowed email ports to be open.
    I could receive but not send, my fix:

    Install Spamassassin
    reboot server, then:
    useradd -g spamd -s /bin/false -d /var/log/spamassassin spamd
    chown spamd:spamd /var/log/spamassassin
    systemctl enable spamassassin
    systemctl start spamassassin

    all started working
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!