CyberHosting

After update version 1.9.3 from 1.9.2 Server Error 500

After update version 1.9.3 from 1.9.2 Server Error 500, I cannot login to CyberPanel.

Comments

  • Also no error after DEBUG = True

    nano /usr/local/CyberCP/CyberCP/settings.py

    You can open this file and turn on debug log and then do systemctl restart lscpd
  • i am having similar issue

    Saving to: ‘wsgi-lsapi-1.4.tgz’

    wsgi-lsapi-1.4.tgz 100%[========================================>] 46.77K 246KB/s in 0.2s

    2020-01-04 16:13:50 (246 KB/s) - ‘wsgi-lsapi-1.4.tgz’ saved [47890/47890]

    Done.
    x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -flto -fuse-linker-plugin -ffat-lto-objects -O0 -g3 -I. -I/usr/include/python3.6m -I. -I/usr/include/python3.6m -c -o main.o main.c
    main.c: In function ‘main’:
    main.c:169:9: warning: implicit declaration of function ‘preload_module’ [-Wimplicit-function-declaration]
    preload_module(moduleName, appName, progName);
    ^~~~~~~~~~~~~~
    x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -flto -fuse-linker-plugin -ffat-lto-objects -O0 -g3 -I. -I/usr/include/python3.6m -I. -I/usr/include/python3.6m -c -o wsgi.o wsgi.c
    x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -flto -fuse-linker-plugin -ffat-lto-objects -O0 -g3 -I. -I/usr/include/python3.6m -I. -I/usr/include/python3.6m -c -o wsgiinput.o wsgiinput.c
    x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -flto -fuse-linker-plugin -ffat-lto-objects -O0 -g3 -I. -I/usr/include/python3.6m -I. -I/usr/include/python3.6m -c -o wsgiwrapper.o wsgiwrapper.c
    x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -flto -fuse-linker-plugin -ffat-lto-objects -O0 -g3 -I. -I/usr/include/python3.6m -I. -I/usr/include/python3.6m -c -o lsapilib.o lsapilib.c
    x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -flto -fuse-linker-plugin -ffat-lto-objects -O0 -g3 -I. -I/usr/include/python3.6m -I. -I/usr/include/python3.6m -c -o lsapi-glue.o lsapi-glue.c
    x86_64-linux-gnu-gcc -pthread -Wl,-Bsymbolic-functions -Wl,-z,relro -L/usr/lib -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions -o lswsgi main.o wsgi.o wsgiinput.o wsgiwrapper.o lsapilib.o lsapi-glue.o -L/usr/lib/python3.6/config-3.6m-x86_64-linux-gnu -lpython3.6m -lpthread -ldl -lutil -lm
    ###################################################################
    CyberPanel Upgraded
    ###################################################################
  • I have same issue.

    In logs found this:

    15494: packetLen < 0
    Traceback (most recent call last):
    File "/usr/local/CyberCP/CyberCP/wsgi.py", line 12, in <module>
    from django.core.wsgi import get_wsgi_application
    ModuleNotFoundError: No module named 'django'
  • I have the same issue.
    Any fix ?
  • Have you guys opened any ticket? If so please let me know your ticket id.
  • Same problem. Upgraded from 1.9.2 already running on Python3 to 1.9.3.

    500
    Internal Server Error
    An internal server error has occured.

    The only messages of note during the upgrade process:

    Installing collected packages: setuptools, pycparser, cffi, six, cryptography, pyOpenSSL, josepy, certifi, idna, chardet, urllib3, requests, pbr, mock, pytz, pyRFC3339, acme, asgiref, asn1crypto, Babel, backports.ssl-match-hostname, bcrypt, jmespath, python-dateutil, docutils, botocore, s3transfer, boto3, zope.event, zope.interface, zope.component, configobj, future, parsedatetime, ConfigArgParse, certbot, decorator, sqlparse, Django, docker-pycreds, websocket-client, docker, enum34, funcsigs, ipaddress, IPy, MarkupSafe, Jinja2, jsonpointer, jsonpatch, mysqlclient, PyNaCl, paramiko, ptyprocess, pexpect, prettytable, psutil, py3dns, pygpgme, pyudev, pyxattr, PyYAML, requests-file, SimpleWebSocketServer, tldextract
    Segmentation fault (core dumped)
    --

    Installing collected packages: pycparser, cffi, six, cryptography, pyOpenSSL, pytz, pyRFC3339, setuptools, josepy, pbr, mock, certifi, chardet, urllib3, idna, requests, acme, asgiref, asn1crypto, Babel, backports.ssl-match-hostname, bcrypt, python-dateutil, docutils, jmespath, botocore, s3transfer, boto3, zope.interface, future, parsedatetime, configobj, ConfigArgParse, zope.event, zope.component, certbot, decorator, sqlparse, Django, docker-pycreds, websocket-client, docker, enum34, funcsigs, ipaddress, IPy, MarkupSafe, Jinja2, jsonpointer, jsonpatch, mysqlclient, PyNaCl, paramiko, ptyprocess, pexpect, prettytable, psutil, py3dns, pygpgme, pyudev, pyxattr, PyYAML, requests-file, SimpleWebSocketServer, tldextract
    Segmentation fault (core dumped)
    --


    System: Ubuntu LTS 18.04.3, fully updated. 2 Xeon cores, 8GiB RAM VPS.
  • @mparashar

    Can you open ticket and let me know Ticket ID.
  • @CyberPanel

    Sure thing. Ticket #Y7P0IF
  • Is there a fix for this yet for those who have the issue ?
  • It was anounced that the bag was only for Ubuntu release and it is fixed.
    I will tell you in a few hours.
  • I can confirm.
    I'm using the AWS image, and I got the same error on some pages of the CyberPanel dashboard.
  • this worked for me

    https://forums.cyberpanel.net/discussion/3659/update-cyberpanel-to-1-93-ubuntu-18-04

    try it and luck!!
  • edited January 7
    Is it safe to update yet for CentOS 7 users?
  • Type your comment> @Hifihedgehog said:
    > Is it safe to update yet for CentOS 7 users?

    You will get an error when you try to go to Version Management menu.
    Apart from that, everything works Ok for me.
  • Type your comment> @ysintos said:
    > Type your comment> @Hifihedgehog said:
    > > Is it safe to update yet for CentOS 7 users?
    >
    > You will get an error when you try to go to Version Management menu.
    > Apart from that, everything works Ok for me.

    I just noticed this as well. Web terminal and renewing SSL's for proxied domain names doesn't works now too.
  • I’m on centos 7 with the same issue. I even made a post here but didn’t get a response...

    https://forums.cyberpanel.net/discussion/3530/500-internal-server-error-after-upgrade#latest
  • > @CyberPanel said:
    > @mparashar
    >
    > Can you open ticket and let me know Ticket ID.

    I have the same issue with centos 7.

    Ticket #KQHLM8
  • I had the same issue and it was due to mysql_config not being installed. I was able to resolve that with apt install libmariadb-dev libmariadb-dev-compat and then rerunning the upgrade script (apt install libmariadbclient-dev did not work during the upgrade script due to version mismatch). This seems to be due to me installing the 10.4 MariaDB instead of using the default 10.1 provided by the Ubuntu repos. Hopefully this may help someone else!
  • > @ikk157 said:
    > > @CyberPanel said:
    > > @mparashar
    > >
    > > Can you open ticket and let me know Ticket ID.
    >
    > I have the same issue with centos 7.
    >
    > Ticket #KQHLM8

    The lovely support team/admins fixed it for me! I can’t thank you enough, my site was down for quite a considerable amount of time but now it’s finally back!
  • Hi Guys!

    Just did the update on CentOS 7 in one of our servers, all went smoothly, few warnings, no errors. Everything flies. I'll do the same in a minute on Ubuntu, we'll see.

    A HINT: I always install CP as root from a root folder. The same with upgrading. It solved ALL my problems with installations in the past and all servers work beautifully since then. I've seen many problems here at forums which I saw in the past when I was acting as a user or sudo user. I think it should be mentioned somewhere in manuals / tutorials. I know it's probably not the best idea due to security reasons (or someone couldn't have such permissions) but after many hours of fights with errors and walls in the past, I havent't got any single issue acting as a root.
  • I tried with Root and I still got the 500 Internal Server error after the update on Centos 7
  • edited January 9
    And has it been installed with root?

    As I mentioned I saw several different errors AFTER installing CP as user, then sudo user. And finally I've read somewhere about some other guy who started from scratch as root after many hours of fighting with errors. And bam: all went just like that. I did the same - started from scratch, reinstalled CentOS, did everything as a root - it worked. And since then we're running several machines built like that without an issue. I've upgraded 2 yesterday smoothly.

    It doesn't have to be a remedy for you for some reason and I'm not a expert here.
    Just sharing our experience.
  • Similar issue. I upgraded to 1.9.3 on CentOS 7 and now I can't login to admin panel. When I login it stuck on login page. When I inspect page I found there is error 500 showing.

    Support Ticket ID #FRX9CF

    Thanks
  • edited January 11
    I see issues with multiple like

    (1665, 'Cannot execute statement: impossible to write to binary log since BINLOG_FORMAT = STATEMENT and at least one table uses a storage engine limited to row-based logging. InnoDB is limited to row-logging when transaction isolation level is READ COMMITTED or READ UNCOMMITTED.')

    If you address this issues, things will go smooth.
  • Possible solution mentioned here -> https://web.facebook.com/groups/cyberpanel/permalink/2394812850830349/
  • I am also getting the same error while login to cyber panel admin.

    Solution Please.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!