CyberHosting

Gandi domain & Wordpress

It seems that domains registered at Gandi using the supplied `live dns' will allow CyberPanel to setup a site but not install Wordpress. I have tried a few times but a database is created only. I have just changed the name-servers to cloudflare and should have no problems once the DNS propogates.
Any info on this matter would be appreciated.

Comments

  • After a lot of frustration and wasted time I have increased my knowledge of DNS, name-servers, glue records and other stuff but the above issue is not quite sorted yet.
    I decided against cloudflare because I don't want to rewire the :8090 port.
    Propagation paranoia had me waiting 72 hours between changing settings to test stuff.
    I had a service switched on at Gandi that may have over-ridden the A record (ip) and the `live-dns' just causes more confusion.
    Trying powerdns on cyberpanel did not work as I am not familiar and got the name-servers/glue records messed up (I know now)
    If it doesn't work this time using Gandi live-dns and A-record to IP I am going to use my server DNS instead (Vultr).
    Yep that's 4 DNS methods, 4 lots of name-servers, a required change of glue records and normal protocol and other stuff.
    All with a supposed 72 hours between any changes.
    It is a one of as my other domains are registered with other registrars.
    Just one domain/wordpress migration giving me headaches after many smooth ones.
  • Above comment `If it doesn't work this time using Gandi live-dns and A-record to IP I am going to use my server DNS instead (Vultr).'
    It didn't.
    I am now going to use my server DNS (Vultr) as external name-servers and see if it will allow me to create a Wordpress site.
    My firewalls on my server allow my IP only to access port :8090.
    This seems to be the issue stopping CyberPanel from setting up the applications WP + LSCache.
    I am commenting on this thread in case someone else gets similar problems.
  • After 2 to 3 weeks and many tries I officially give up on installing a Wordpress site using CyberPanel on my Gandi domain.
    I have easily and successfully installed WP + LSCache on 16 domains created on the current CyberPanel 1.93 Ubuntu 18.04 server over the last few weeks.
    The domains are registered with other registars though.
    I have tried and double checked lots of potential issues and configured/tuned my server, CyberPanel and a few other things.
    I still have a few ideas as to what the cause may be but not the time to waste . Suffice to say that Gandi & Cloudflare are not on my fave services list at this time.
    Some options in cloudflare can break a domain and some recent changes (ssl,http2,dnsec,modsec,etc.) compound issues.
    The Gandi domain functions and has been on a few Nameservers recently with functional MX, txt & cname records.
    I have initiated redirecting the domain to a Wordpress site I have setup to resolve the problems.
  • edited January 20
    Quick resolution for now: good SEO, full https (all points), quick, easy, no waiting for DNS to propagate (30 mins)
    Using Cloudflare DNS / nameservers (the domain on Gandi)
    Page rule > redirect (permanent) to my setup Wordpress domain.
    result? > https://newera.cloud (try the url and see what happens)
  • I quickly sorted this annoying situation out today.
    I installed a small droplet consisting of Ubuntu 18.04 with Wordpress + OpenLiteSpeed + LSCache ( https://docs.litespeedtech.com/cloud/wordpress )
    This took a matter of minutes using Cloudflare DNS / Nameservers pointed at the floating IP. I now have a raw litespeed server with dedicated IP to fine tune and another testing zone for devs. 🌤️ All good in the end at ⚡ https://Newera.Cloud 🌪 on litespeed 2020 🌩️
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion