Permanent Connections / Rewrite Rules

Our opencart board site does not work in any way with permanent connections.

The current rewrite rules in the file have been fetched.

Still, the problem continues.
The page you were looking for was not found.
this error only applies to the SEO-compliant url.

Comments

  • Paste your rewrite rules, and do you have rules in sub-dirs too?
  • edited May 21
    No rules in subdirectories.
    I pasted the rewrite rules.
    But the result hasn't changed.

    The existing rules are as follows.
    the contents of our htaccess file are in the link.

    https://goo.gl/L8okzD
  • Try these rules
    # 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

    # 2. In your opencart directory rename htaccess.txt to .htaccess.

    # For any support issues please visit: http://www.opencart.com

    Options +FollowSymlinks

    # Prevent Directoy listing
    Options -Indexes

    # Prevent Direct Access to files

    Order deny,allow
    Deny from all


    # SEO URL Settings
    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www\.aktifon\.com
    RewriteRule /(.*) https://www.aktifon.com/$1 [R=301,L]
    # If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

    RewriteBase /
    RewriteRule ^/sitemap.xml$ index.php?route=feed/google_sitemap [L]
    RewriteRule ^/googlebase.xml$ index.php?route=feed/google_base [L]
    RewriteRule ^/system/download/(.*) index.php?route=error/not_found [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
    RewriteRule ^/([^?]*) index.php?_route_=$1 [L,QSA]

    ### Additional Settings that may need to be enabled for some servers
    ### Uncomment the commands by removing the # sign in front of it.
    ### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

    # 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
    # php_flag register_globals off

    # 2. If your cart has magic quotes enabled, This may work to disable it:
    # php_flag magic_quotes_gpc Off

    # 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
    # php_value upload_max_filesize 999M

    # 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
    # php_value post_max_size 999M

    # 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
    # php_value max_execution_time 200

    # 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
    # php_value max_input_time 200

    # 7. disable open_basedir limitations
    # php_admin_value open_basedir none
    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^/.*$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
  • Yes, now it is.
    I thank you.
    That was the problem.
    There are dozens of websites like this one.
    I'd like to solve this myself.
    can you tell me what's wrong?
  • RewriteRule ^/.*\.(log|ini|tpl|txt)$ - [F,L,NC]
    RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
    RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
    RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
    RewriteRule ^/([^?]*) index.php?_route_=$1 [L,QSA]
    try this



Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!