CyberHosting

Error message: 'NoneType' object has no attribute 'splitlines'

Provider: VirMach

Virtualization Type: KVM.

System: Ubuntu 18.04

Installation option: since during the installation.
there will be few option to choose,so please provide it as well.

OLS or Enterprise?
OLS

Installing from official server or mirror server?
official


Replace JS/CSS files to JS Delivr?
no

Install Memcached extension for PHP?
No idea (I didn't install any extensions manually, everything is default).

Install LiteSpeed Memcached?
Yes (selected this option at installation).

Install Memcached?
Yes during initial installation.

Install Redis extension for PHP?
No.

Install Redis?
Yes


Problem:

I get this error when I try to create a new website.:
Error message: 'NoneType' object has no attribute 'splitlines'

I successfully created a new website yesterday but today I am getting this error.

I chose default package and the user is admin only.

First I tried with selecting all the options which I get at the end which is DKIM support, SSL, base_dir protection and then unselecting all these options but still I am getting this error.

I checked the error logs and it's empty.

Comments

  • @CyberPanel

    Can you please look into this issue?
  • Sorry for your trouble, there is an issue with LSCPD. Please update your lscpd binary using following commands

    wget https://cyberpanel.sh/lscpd -P /usr/local/lscp/bin/lscpd
    systemctl restart lscpd
  • This worked for me and ensures the 755 priveleges in case anyone who puts file there has an issue starting it still.
    rm -rf /usr/local/lscp/bin/lscpd/; wget -O /usr/local/lscp/bin/lscpd https://cyberpanel.sh/lscpd; chmod +x /usr/local/lscp/bin/lscpd; systemctl restart lscpd;
  • > @CyberPanel said:
    > Sorry for your trouble, there is an issue with LSCPD. Please update your lscpd binary using following commands
    >
    > wget https://cyberpanel.sh/lscpd -P /usr/local/lscp/bin/lscpd
    > systemctl restart lscpd

    Thank you. I'm trying now.

    > @whattheserver said:
    > This worked for me and ensures the 755 priveleges in case anyone who puts file there has an issue starting it still.
    > rm -rf /usr/local/lscp/bin/lscpd/; wget -O /usr/local/lscp/bin/lscpd https://cyberpanel.sh/lscpd; chmod +x /usr/local/lscp/bin/lscpd; systemctl restart lscpd;

    Thank you. I will try this if above solution doesn't work.
  • It was not letting me restart lscpd and it threw an error:
    Job for lscpd.service failed because ...

    The solution provided by whattheserver worked like charm.
  • Glad to hear that worked for you.
  • I'm having this issue when I'm trying to setup email forward for child domain.

    It works fine with pipe option.

    With email forward option as below

    cyberpanel 'NoneType' object has no attribute 'domain'

    Already tried suggested solution.

    Can anyone test on your setup and let me know if you can do this option for child domains?

    Also this domain missing on child domains list so I cant convert.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!