CyberHosting

Unabled to Login to Panel

edited February 7 in Bug Report
After upgrading to 1.94, I am unable to login to the panel. It is stuck forever at the login page after hitting the sign in button.

OS - Centos 7
Litespeed version - OLS

Comments

  • Sounds like you need to give permissions for ports 8090 and 22 on your server firewall to allow your routers IP. If your IP changes when you connect on your desktop pc (common), you need to change permissions each time before you can login to CyberPanel.
  • edited February 8
    Even when the ports are open? Firewall is not blocking the connection.
  • Disable MySQL binary logging -> https://blog.hartwork.org/posts/how-to-disable-mysql-binary-logging/
  • For my part, on 2 servers, I can't even reach the login page on port 8090 after upgrade to 1.9.4. I tried disabling MySQL binary logging to no success. I get error 500 or 503.
    Do you have an idea what could be the issue?
  • edited February 12
    The same problem
    Not working > @CyberPanel said:
    > Disable MySQL binary logging -> https://blog.hartwork.org/posts/how-to-disable-mysql-binary-logging/

    Not working
  • same problem
    @CyberPanel don't work still error 503

    MariaDB [(none)]> SHOW VARIABLES LIKE 'log_bin';
    +---------------+-------+
    | Variable_name | Value |
    +---------------+-------+
    | log_bin | OFF |
    +---------------+-------+
    1 row in set (0.00 sec)
  • FYI, bug has been fixed. Just upgrade again.
  • edited February 14
    same problem after upgrade

    i find the solution

    ### in this file ####

    /usr/local/CyberCP/loginSystem/templates/loginSystem/login.html

    ### find ###
    <script src="https://code.angularjs.org/1.6.5/angular.min.js"></script>
    <script src="https://code.angularjs.org/1.6.5/angular-route.min.js"></script>

    ### and replace with ###

    <script src="https://ajax.googleapis.com/ajax/libs/angularjs/1.6.9/angular.min.js"></script>
    <script src="https://ajax.googleapis.com/ajax/libs/angularjs/1.6.9/angular-route.min.js"></script>
    ______________________________________________________________________________________

    ### in this files ####
    /usr/local/CyberCP/baseTemplate/templates/baseTemplate/index.html
    /usr/local/CyberCP/filemanager/templates/filemanager/index.html

    ### find ###
    <script src="https://code.angularjs.org/1.6.5/angular.min.js"></script>

    ### and replace with ###
    <script src="https://ajax.googleapis.com/ajax/libs/angularjs/1.6.9/angular.min.js"></script>
    ______________________________________________________________________________________

    after that "reboot" your server
  • edited February 18
    Type your comment> @samyhossam said:
    > The same problem
    > Not working > @CyberPanel said:
    > > Disable MySQL binary logging -> https://blog.hartwork.org/posts/how-to-disable-mysql-binary-logging/
    >
    > Not working
    >
    >

    Make sure that there's no `log-bin` line anywhere else in your /etc/my.cnf
    Verify that binary logging is disabled my running `SHOW VARIABLES LIKE 'log_bin';` in mysql and confirm it's OFF.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!