PHP Upload Size Doesn't Increase — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

PHP Upload Size Doesn't Increase

edited February 9 in Database Server
Similar title, why my PHP upload size doesn't increase althought i have edit in PHP config step by step:
https://cyberpanel.net/docs/4-change-upload-limit-for-phpmyadmin/
I'm using PHP version 7.0

Error Image:
https://i.imgur.com/UmZld9G.png
https://i.imgur.com/pNW8kcT.png

Comments

  • Please help me, thanks so much
  • You need to restart the service to see the increase. pkill lsphp
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • I am also facing same problem limit doesn't increase.
    I did all on here
    https://cyberpanel.net/docs/4-change-upload-limit-for-phpmyadmin/

    and its still 2mb
  • If you are running the latest version then you are not running on php 7.0 so change the values for the correct php version. Cyberpanel runs on php 7.3
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • I did it for php 7.3 few minutes ago as attached screenshots below.

    https://imgur.com/q5ZnJtn
    https://imgur.com/Jo5CbPm
    https://imgur.com/brBTYQn
    https://imgur.com/gJjzdUM
    https://imgur.com/pchVuex

    Whats wrong?
  • You restarted lscpd. You need to restart lsws and kill the php process

    login to the ols webadmin on port 7080 and restart it from there or use command line
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • If using the PHP Config edit tool in CP, why does it not do the necessary restarting of the PHP process? Wouldn't that be the logical way to do it? Rather than the user having to hit the command line and do it themselves?
  • @neweracloud only because WP insists on putting in limits into their code which are 99.9% of the time not suitable.

    @inspiredearth discussed this morning. The plan is to implement a vhost level restart of php. For example if you change php version for a website it will restart or give you the option to restart.

    Then the option or auto restart on a server level basis when you edit the php configs.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • i restored lsws using command /etc/init.d/lsws restart
    I killed php using command killall php

    Still no luck php upload limit doesn't increase
  • killall php won't work seen as it's openlitespeed and they name their packages lsphp
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • Can you give me command for killing php process on openlitespeed
  • They name their packages lsphp

    What do you think?
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • right now, i have same problems & can not fix it . i try to restart service & change setting for all php version but can not
  • i try to edit php.ini at root folder & kill all php . it's working now
  • I had the same problem as well. Only after rebooting the hardware it started to work.
  • The reason why it doesnt change instantly is because of this feature

    https://openlitespeed.org/kb/php-detached-mode/
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • At the end which are the commands to solve this issue? :-D
  • pkill lsphp
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • Type your comment> @hennaboy said:
    > pkill lsphp

    does not work, I also tried to restart ls but the php upload limit does not change
  • Hi anyone managed to increase the upload size?
  • Type your comment> @Wyzzy said:
    > Type your comment> @hennaboy said:
    > > pkill lsphp
    >
    > does not work, I also tried to restart ls but the php upload limit does not change

    you are not changing the correct php.ini then
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • I had the same issue, no amount of changes to php.ini and rebooting would increase the upload size and I could not import my database. I suggest a more sensible default value of say 64mb would be better.

    Fortunately it is quite simple to import a database by ssh. Just upload mysql file to home folder via filemanager or ftp (/home/yourdomain.com) then log into ssh and change directory with cd /home/yourdomain.com then run this command.

    mysql -p -u user_name database_name < file.sql changing the values to that of your mysql database, press enter and you will be prompted for your mysql user passwd press enter again job done.
  • But then the next person comes along and requires a default of 128M then 512M and so on.

    As per many other posts on this subject the answer is and will always be that you need to change the values in php.ini and then kill the PHP process for it to take effect.

    This is a litespeed/openlitespeed method and Cyberpanel has everything including the write the restart file in place to make the changes.

    If you want a default higher value you will need to lobby litespeed for it.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • I take your point but 2mb may as well be 0mb as no one is going to import a database smaller than 2mbs. As for imports larger than 64 Mbs, they are better done by ssh anyway as you would probably hit the php timeout with average broadband upload speeds.
  • On CP admin, go to edit PHP Configurations and change values for php7.2

    (that version it's used by phpmyadmin on CP2.0)

    > @huuthi95 said:
    > Similar title, why my PHP upload size doesn't increase althought i have edit in PHP config step by step:
    > https://cyberpanel.net/docs/4-change-upload-limit-for-phpmyadmin/
    > I'm using PHP version 7.0
    >
    > Error Image:
    > https://i.imgur.com/UmZld9G.png
    > https://i.imgur.com/pNW8kcT.png
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!