Config auto_prepend_file does not work. — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

Config auto_prepend_file does not work.

I'm using CyberPanel with LiteSpeed Enterprise version to active a WAF using the PHP configuration:
auto_prepend_file=waf.php

But this configuration does not work.

Comments

  • I'm using the Ninja Firewall WAF for a couple of WordPress sites, and here's what I have to do – maybe you can do the same thing, just point to your php file.

    In CyberPanel you can go to Manage Website, and click on vHost Conf. Scroll down to "phpIniOverride {" or create it, and add your line inside the brackets:

    php_value auto_prepend_file /home/yourdomain.com/public_html/path/to/waf.php

    You can also enter this directive inside the OLS web panel if you're using that, under the Virtual Host settings for this particular site. I believe it's just a text field called "php.ini overrides"
  • Hi,
    I am trying to figure this out, I entered as suggested by Ninja Firewall:
    php_value auto_prepend_file "/home/mydomain.com/public_html/wp-content/nfwlog/ninjafirewall.php"
    But it does not activate.
    I am using the free LiteSpeed.
    Anyone got it working?
    Thanks
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion