CyberHosting

Cannot Install ModSecurity Rule Packs (Fresh Install)

Hi I installed CyberPanel 1.9.4 on a new VPS server. I am encountering error in installing ModSecurity Packs and neither OWASP and Comodo can be installed. Here are the errors:

For OWASP:
Operation failed, Error message: --2020-03-19 07:26:04-- https://cyberpanel.net/modsec/owasp.tar.gz Resolving cyberpanel.net (cyberpanel.net)... 2606:4700:3033::681b:a395, 2606:4700:3034::681b:a295, 104.27.162.149, ... Connecting to cyberpanel.net (cyberpanel.net)|2606:4700:3033::681b:a395|:443... connected. HTTP request sent, awaiting response... 301 Moved Permanently Location: https://cyberpanel.sh/modsec/owasp.tar.gz [following] --2020-03-19 07:26:05-- https://cyberpanel.sh/modsec/owasp.tar.gz Resolving cyberpanel.sh (cyberpanel.sh)... 2001:470:c:d08::2, 89.208.248.38 Connecting to cyberpanel.sh (cyberpanel.sh)|2001:470:c:d08::2|:443... connected. HTTP request sent, awaiting response... 200 OK Length: 1316 (1.3K) [text/html] Saving to: ‘owasp.tar.gz’ 0K . 100% 30.6M=0s 2020-03-19 07:26:06 (30.6 MB/s) - ‘owasp.tar.gz’ saved [1316/1316] 0, Unable to download OWASP Rules.

For Comodo:
Operation failed, Error message: --2020-03-19 07:26:58-- https://cyberpanel.net/modsec/comodo.tar.gz Resolving cyberpanel.net (cyberpanel.net)... 2606:4700:3034::681b:a295, 2606:4700:3033::681b:a395, 104.27.162.149, ... Connecting to cyberpanel.net (cyberpanel.net)|2606:4700:3034::681b:a295|:443... connected. HTTP request sent, awaiting response... 301 Moved Permanently Location: https://cyberpanel.sh/modsec/comodo.tar.gz [following] --2020-03-19 07:26:59-- https://cyberpanel.sh/modsec/comodo.tar.gz Resolving cyberpanel.sh (cyberpanel.sh)... 2001:470:c:d08::2, 89.208.248.38 Connecting to cyberpanel.sh (cyberpanel.sh)|2001:470:c:d08::2|:443... connected. HTTP request sent, awaiting response... 200 OK Length: 1316 (1.3K) [text/html] Saving to: ‘comodo.tar.gz’ 0K . 100% 70.0M=0s 2020-03-19 07:27:00 (70.0 MB/s) - ‘comodo.tar.gz’ saved [1316/1316] 0, Unable to download Comodo Rules.

Comments

  • reinstall again
    ss digital studio : http://www.ssweddingphotography.com
  • I reformat OS, reinstall CyberPanel and even upgrade to version 1.9.5 but still cannot install any ModSecurity packs. This is the 1st time it happen because I installed CyberPanel countless times.
  • 1.9.5 is not the latest version use 1.9.4

    1.9.5 is development will contain bugs.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • Installed on 1.9.4 with no issue. Check your ipv6 connectivity.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • Like I said I installed and reinstalled version 1.9.4. I just tried 1.9.5 to troubleshoot but all cannot install ModSecurity. It is due to the new Open LiteSpeed 1.6.10 because when I upgrade to Litespeed Enterprise, ModSecurity was installed.
    Also I installed version 1.9.4 many times without issue when it was still using Open LiteSpeed 1.6.9.
  • Litespeed enterprise is a different product to openlitespeed.

    This is not related to old 1.6.10 either as I have installed that manually on a test box and could install modsec rule packs.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • Issue was IPv6 it has been removed from DNS for downloading the rulepack. Try again now.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • Yes not 1.6.10 because lower versions also not work. Thanks now installed Rule pack in latest Open LiteSpeed.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!