CyberHosting

Ubuntu server 20.04 LTS support

Hello there,

Now that Ubuntu 20.04 LTS is on the line and will soon be released, does cyberpanel support it?

Or will it need to be updated to make it compatible?

Thanks.

Comments

  • Hard to say until its released and even then it will depend if all packages are available in the repository. It has taken two releases of centos 8 and some packages are still only available on private pay by subscription repositories.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • > @hennaboy said:
    > Hard to say until its released and even then it will depend if all packages are available in the repository. It has taken two releases of centos 8 and some packages are still only available on private pay by subscription repositories.

    Aren’t the beta versions of ubuntu server 20.04 LTS by any chance useful to get this information?
  • You would need to attempt this yourself by getting the ISO then loading it onto your server.

    No providers will be supplying it so you will need to custom install it yourself.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • Type your comment> @hennaboy said:
    > You would need to attempt this yourself by getting the ISO then loading it onto your server.
    >
    > No providers will be supplying it so you will need to custom install it yourself.

    I’ll try it out in a VM and see if it works.
  • Type your comment> @hennaboy said:
    > You would need to attempt this yourself by getting the ISO then loading it onto your server.
    >
    > No providers will be supplying it so you will need to custom install it yourself.

    I wasn’t able to bypass the installation script’s OS check
  • Update:

    I’ve manually bypassed the OS check and set the OS to ubuntu.

    However, when the script tries to install the packages, I get this error:


    Installing necessary components...
    Hit:1 http://om.archive.ubuntu.com/ubuntu focal InRelease
    Hit:2 http://om.archive.ubuntu.com/ubuntu focal-updates InRelease
    Hit:3 http://om.archive.ubuntu.com/ubuntu focal-backports InRelease
    Hit:4 http://om.archive.ubuntu.com/ubuntu focal-security InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    All packages are up to date.
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package python is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    python2-minimal python2 python-is-python2 2to3 python-is-python3

    Package python-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    python2-dev python2 python-dev-is-python2 python-dev-is-python3

    Package python-mysqldb is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package python-minimal is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    python2-minimal

    E: Package 'python-mysqldb' has no installation candidate
    E: Package 'python-dev' has no installation candidate
    E: Unable to locate package python-gpg
    E: Package 'python' has no installation candidate
    E: Package 'python-minimal' has no installation candidate
    E: Package 'python-dev' has no installation candidate
    E: Unable to locate package python-pip

    command failed, exiting...
    [email protected]:~#
  • Patience young padawan...... ubuntu 20 will come in time.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • > @hennaboy said:
    > Patience young padawan...... ubuntu 20 will come in time.

    Haha the suspense kills
  • 2.0.1 Ive tested Ubuntu 20. It is working fine.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
  • @hennaboy Is it possible to install 2.0 in Ubuntu 20 (or CentOS 8) then upgrade to 2.0.1 using the upgrade url and operate Cyberpanel?
  • Type your comment> @themew said:
    > @hennaboy Is it possible to install 2.0 in Ubuntu 20 (or CentOS 8) then upgrade to 2.0.1 using the upgrade url and operate Cyberpanel?

    No
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.
    https://www.cyberhosting.org
    You can now earn with the Cyberhosting affiliate scheme. Join today
    https://www.cyberhosting.org/affiliates/
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!