CyberHosting

404 error after upgrade 2.0

ı update my al vps to cyberpanel 2.0. And have this problem new child domains now. Old domain and child domains not problem. New domain not tested.

excuse me my bad english

Comments

  • what version of openlitespeed?
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • I dont know. How can i learn it.
    my cyberpanel old version is 1,9 . I upgrade 1.9 to 2.0 .
  • /usr/local/lsws/bin/lshttpd -v
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • I have tested on my v2.0 cyberpanel and can create child domain without a problem.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • new install is no problem.
    only have problem when update
  • LiteSpeed/1.6.12 Open
    module versions:
    modgzip 1.1
    cache 1.62
    modinspector 1.1
    uploadprogress 1.1
    mod_security 1.3
    (built: Thu Apr 9 17:38:26 UTC 2020)
    module versions:
    modgzip 1.1
    cache 1.62
    modinspector 1.1
    uploadprogress 1.1
    mod_security 1.3
  • Don't have any issue on update either.

    Create child domain I get the default index page
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • I just realized
    first nineteen domains work on this VPS. But not work more.
  • Look at what services are running what is not running and what error logs say.
    Cyberpanel Managed & Unmanaged Shared & VPS Hosting by Cyberpanel Experts.

    https://www.cyberhosting.org
  • Do one thing.
    Go to modify domain and switch back to different version.
    Now refresh the website.
    Again switch back them to original php version.
    It may solve the issue
  • @bijay thank you
    but unfortunately
    the problem continues
  • edited April 15
    Message me so that i can have a check the exact issue. @sertsidk
  • i think ; i find my error just now.

    httpd_config.conf file damaged over time and I think working with multiple domains contributes to this. Because I have encountered this problem more than once.but others don't have the same problem
    i use 50 or 60 mixed domain or subdomain on my vps. Up to 15-20 no problem. But problem is more use domain or subdomain. there is this text in some parts of the file
    "NUL NULNUL NULNUL NULNUL NULNUL NULNUL NULNUL NULNUL NUL". And; the problem goes away when you delete them

    I want it to be known;
    this problem started with 2.0 version.

    Is there a permanent solution to this?
  • Not sure if this will work for you but you can try it. Go to file manager then select all files and click fix permission
  • > @h1dd3n_sn1p3r said:
    > Not sure if this will work for you but you can try it. Go to file manager then select all files and click fix permission

    no;
    httpd_config.conf file in /usr/local/lsws/conf folders. Not in home directory.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!