Cloudlinux CageFS - LVEManager - Failed to open page — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Cloudlinux CageFS - LVEManager - Failed to open page

This evening I wanted to test the Cyberpanel + Cloudlinux + CageFS
First was a standard CentOS Cyberpanel install and converted to Cloudlinux +CageFS using the tutorial (https://cyberpanel.net/docs/1-convert-cyberpanel-server-to-cloudlinux-os/)

Test environment, a KVM VPS 1vCPU 2Gb
All conversion process was OK then reboot.
Activated / installed CageFS from Cyberpanel.

The first impression after reboot and is that CPU usage is a little higher, fluctuating from 1% to 10% and some spikes at 80% from time to time.

At some point, in the LVE Manager at port 9000, some Wizard fatal error appeared in the top right corner.
After a page refresh, the LVE Manager page can't be accessed anymore.
The browser can't open the page. Can't connect to server 9000 port.

Double checked in the firewall, all seems ok.
service lvestats restart
reboot

The same problem, can't access the LVE manager anymore.
Any idea? Thank you

Comments

  • The solution for me was to reinstall LVE packages with the following command
    yum reinstall lve*

    Furthermore, I did not find a tutorial related to other configurations for using Cloudlinux.
    What other Cludlinux modules can we use with Cyperpanel.
    For example, is MySQL Governor compatible?
  • edited April 2020
    New results after various tests:
    - after any reboot, the LVE Manager page is down - need to reinstall it using yum reinstall lve*
    - if the LVE Manager page are opened, Cyberpanel can't fetch any logs.
    (cyperpanel logs, access logs, error logs etc.)
    Could not fetch logs. Use the command line to view the log file.

    The above problem persists.
    Here I stopped the experiments, I want to test the Mysql Governor too, but for the moment I'll wait.
  • Enjoy your accelerated Internet by CyberPanel.

    [[email protected] ~]# tail -f /var/log/lve-stats.log
    2020-04-23 16:23:35,591: (SnapshotSaver) [INFO] apache webserver will be used now to obtain data
    2020-04-23 16:23:35,685: (SnapshotSaver) [INFO] SQL snapshot is not supported by this control panel: CloudLinux control panel API: db_access is not supported by this control panel
    2020-04-23 17:49:35,624: (plugin_sigusr2_handler) [INFO] Shutting down plugin
    2020-04-23 17:49:35,644: (main_loop.plugin_executor.process) [INFO] Plugin <class 'lvestats.plugins.generic.snapshot_saver.SnapshotSaver'> was terminated.
    2020-04-23 17:49:35,634: (sigterm_handler) [INFO] SIGTERM handler. Shutting Down.
    2020-04-23 17:49:37,619: (init_db_engine) [INFO] Connecting to database: sqlite
    2020-04-23 17:49:37,721: (server) [INFO] Starting main() in daemon
    2020-04-23 17:49:38,021: (init_db_engine) [INFO] Connecting to database: sqlite
    2020-04-23 17:49:38,042: (SnapshotSaver) [INFO] apache webserver will be used now to obtain data
    2020-04-23 17:49:38,129: (SnapshotSaver) [INFO] SQL snapshot is not supported by this control panel: CloudLinux control panel API: db_access is not supported by this control panel
  • Type your comment
  • After a few hours with Cloudlinux support, they discovered the reason LVE manager is down after reboot:

    basically, there's an lvemanager service which, in a nutshell, is a command
    /opt/alt/python37/bin/python3.7 /usr/bin/lvemanager-service
    The "/usr/bin/lvemanager-service" part is a symlink to "/usr/share/l.v.e-manager/panelless-version/daemon/server.py" file. The idea is that this service should be started at system's boot and spawn a process that would listen on port 9000 and would enable access to the LVE Manager GUI.

    At the moment, however, the service is disable in systemctl presets for some reason. And I'm not able to change that, i.e. editing /usr/lib/systemd/system-preset/90-systemd.preset​ file or using systemctl to enable the service on startup doesn't seem to work. And that's really weird.

    For the time being, a workaround - enable/start the service by using the following command

    service lvemanager start​
  • In the root crontab try adding the below:
    @reboot service lvemanager start​

    That should start it on boot/reboot
  • Thanks for the idea, I'll give a try.
  • edited April 2020
    @chiareu

    I have checked on fresh installation of CloudLinux that CPU usage spikes only when LVEManager is being used.

    However, when I closed lvemanager window CPU usage goes back to normal. So this situation is out of our hands. Seems LVEManager use good amount of resources when in use.

    Apart from so far we've only implemeneted

    1. CageFS.
    2. CloudLinux limits.

    Other features from CloudLinux are not yet implemented. Now I am checking other things.
  • @CyberPanel
    Indeed the problem persists only as the LVEManager page are open.
    After we close the page, even the logs are fetched normally.
  • l am can't access LVEManager the port is open but it doesn't load
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!