Package conflict in onigurama & lsphp74-mbstring — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Package conflict in onigurama & lsphp74-mbstring

CentOS 7. Repos installed comes from CyberPanel installation. Recently I'm getting following error on yum update:

Resolving Dependencies
--> Running transaction check
---> Package oniguruma.x86_64 0:5.9.5-3.el7 will be updated
--> Processing Dependency: libonig.so.2()(64bit) for package: lsphp74-mbstring-7.4.6-1.el7.x86_64
---> Package oniguruma.x86_64 0:6.8.2-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: lsphp74-mbstring-7.4.6-1.el7.x86_64 (installed)
Requires: libonig.so.2()(64bit)
Removing: oniguruma-5.9.5-3.el7.x86_64 (@epel)
libonig.so.2()(64bit)
Updated By: oniguruma-6.8.2-1.el7.x86_64 (epel)
~libonig.so.5()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Comments

  • @hennaboy yes, but litespeed-mirror are maintained by Cyberpanel:

    baseurl=https://cdn.cyberpanel.sh/litespeed/x86_64

    So I guess its up to its maintainers to re-compile this module with the updated library version (oniguruma which comes from EPEL).
  • @hennaboy I see, thanks. From the repo URL I thought that it was cyberpanel custom repo. Will direct this message to OLS forums.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion