Clean Install, Poor Performance — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Clean Install, Poor Performance

I'm using Google Cloud, 2 CPU and 4 GB memory. CentOS 8 with cyberpanel and openlitespeed.

Installed clean wordpress from cyberpanel. Install and setup litespeed cache with redis running.

Now, here's the fun part...
Tested my homepage (clean wordpress theme) using loader.io with 10k traffic in 1 minutes. No issue. error rate was very low with 0.1%.

Create a new page. Just a test page. Fill with title and a bit text content. Send 10k traffic in 1 minutes. Failed in the process.

Send 4k traffic in 1 minutes. Failed in the process. Error rate is more than 56%.

Send 2k traffic in 1 minutes. Process runs till the end. Error rate is 12%.

Is this normal? Is there any settings that I need to change from the default ones to make it better?

But why does it happen in the internal page and no issue with the homepage? I even tried to change the server from google cloud to digital ocean and vultr. All are giving the same results.

Anyone can help figuring this out? Many thanks.

Comments

  • OK from what I look, the problem resides on the CPU core. I try to upgrade my CPU cores to 4 CPU cores and I can handle the traffic with no problem at all using all the default setup.

    But again, I don't know whether this is optimal or not but it works for me.
  • Google Cloud's CPU performance is pathetic. Try some other provider.
  • I've tried so many of them... google, vultr, digital ocean, upcloud. Neither of them passed the test with 10k traffic in 1 mins with 2 cores. Upgrading to 4 cores definitely solves the issue.

    Oh, even better if you use litespeed enterprise. Better caching and better handling huge traffic. Saw the difference when testing.
  • edited July 2020
    Type your comment> @andesjeslis said:
    > I've tried so many of them... google, vultr, digital ocean, upcloud. Neither of them passed the test with 10k traffic in 1 mins with 2 cores. Upgrading to 4 cores definitely solves the issue.
    >
    > Oh, even better if you use litespeed enterprise. Better caching and better handling huge traffic. Saw the difference when testing.

    Impressive!Thanks for the post
  • +1 Agreed. Thanks for the post. Wish we could upvote a great response :)
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!