Some obstacles and bugs from my point of view — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

Some obstacles and bugs from my point of view

Dear Cyberpanel Team

Let me introduce myself, I'm Ahnaf Fauzan and still studying at a vocational high school in Indonesia.
I was very interested in cyberpanel and then installed it on my Google Cloud, but I encountered several obstacles when using it.

1. ssl cyberpanel gets a warning from the browser.
but it can still be overcome: https://blog.cyberpanel.net/2018/05/03/how-to-setup-custom-ssl-with-cyberpanel/
2. at first I didn't know that I had to use the command "sudo su -" not just "sudo su".
but this is only a trivial matter
3. I do not know what ports are needed.
like I just found out that TCP 53 port must be opened when I want to use DNS service
4. Ubuntu OS has been supported but Debian has not.
actually this is not a problem
5. there are only fix permissions.
hopefully in the future cyberpanel can set permissions such as chmod 777, chmod 755, etc
6. install php extension does not work.
some php extensions must be installed manually like ioncube =
https://forums.cyberpanel.net/discussion/228/install-ioncube-loader-on-openlitespeed
7. unable to install the docker.
almost like ioncube at number 7, but this time I haven't got the solution
8. cyberpanel plugin.
I don't know the plugin function in cyberpanel, even I don't know what plugins are available
9. ssh and web terminal does not work.
I haven't found a solution yet, but one of the moderators at Discord says it's because I use Google Cloud
10. I installed the ekattor but got an error.
I am not sure where the error is, but I have tried installing the ekattor on shared hosting and that is normal

sorry if my English is bad.
honestly I really like cyberpanel, I really hope cyberpanel will be better.
I am very grateful to the cyberpanel team:)

<<NOTES>>
+ I use VM on Google Cloud with Centos 8 and Python3

Comments

  • thank you for the answer, hopefully cyberpanel can be even better for the future:)
  • <<continued numbers 3 and 9>>
    the good news is I found a solution for number 9 after sending a ticket to https://platform.cyberpanel.net
    he said he had to open port 5678 for the terminal website to work.
    this is what I mean at number 3, in order to list the required ports.
    .
    after learning that port 5678 must be opened I tried opening it via UWW, cyberpanel firewall, and cmd-firewall but failed.
    after reading the documentation more thoroughly it turns out I had to open it through CSF Cyberpanel and it worked.
    .
    I hope friends who experience the same obstacles can be helped
  • edited July 5
    thank you very much for the answer
    I made this only to help friends if they have the same problem.
    I support cyberpanel and really hope for it
    .
    if I find a solution to my problem above, I will tell it here
  • thank you very much
    it worked
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion