Changing the UI of templates for personal use — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

Changing the UI of templates for personal use

I have edited some text in login template of cyberpanel on my server. Even after restarting my server several times, no changes are occuring! Can you help to make those changes appear thanks...

Comments

  • Thanks for your reply. But currently i am not using any translation. I have just put some text i.e. abc . Do I need to compile even for that? Thanks in Advance
  • Ok Thanks! Let me try. I will update you with the results
  • I am newbie in python and django to be honest. I have searched on the internet but they are saying the code is compiled automatically. Since, i am making changes directly on my deployed cpanel server, i dont see any changes been made. I request you to please help me in this regards as i want to change the complete theme of cyberpanel for personal use. I have also tried the guide in in the link below
    https://forums.cyberpanel.net/discussion/1153/change-default-template-cyberpanel
    the reply by "whattheserver" didn't work. None of my custom css files and images moved to static folder!

    Just a little guide and help will be appreciated thanks.
  • your static file must be upload in this static folder /CyperCP/public/static/baseTemplate not in /CyperCP/baseTemplate /static/baseTemplate. And after you changing any html file you need to use comand line to restart litespeed example 'systemctl restart lscpd'
  • Thanks you so much for your reply. Hope you are having a fine day.
    There is no public/static folder although there is a static folder... I have used collectstatic command on manage.py by python. That method moved the files(css and images) to that static folder at right place. But those files are not accessible through address, also some of the default images are not accessible/loading.
    Secondly after making changes in the html. I have tried all the following things still no changes are appearing:
    1. Tried systemctl restart lscpd
    2. Tried systemctl restart lsws
    3. Tried restarting the server with reboot
    4. Cleared browser cache
    5. Repeated the above steps after enabling the debugging

    I also read the install.sh script and cyberpanel_uprade.sh script to understand

    Note: i am using ssh to make changes in the html files using root account. My ultimate goal to make the theme as much close to cpanel(for the users) and if possible i will also change the workflow to match theirs. If successful i will happily push the code to the git.

    Further help will also be appreciated thanks.
  • I think i am working on a wrong directory. Thanks for your help. Will contact if I face further problem in this regards...
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!