WordPress Snippets plugin 404 — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

WordPress Snippets plugin 404

Hi,

I'm trying to create a custom page in My Account section of Woocommerce, but when I open this page I get 404 (Page not found). I tried to re-save (refresh) the permalinks in Settings -> Permalinks, but nothing changes (again 404 - Page not found). I'm using this permalink type "https://mywebsite.com/sample-post/". When I change the permalink type to "https://mywebsite.com/?p=123" it is working and the page shows. Can somebody tell me where is the problem and why it's working with "Plain" permalinks, but it's not working with "Post name" permalinks ? Here is my code snippet:

----------------------------------------------------------------------------

// 1. Register new endpoint to use for My Account page
// Note: Resave Permalinks or it will give 404 error

function bbloomer_add_premium_support_endpoint() {
add_rewrite_endpoint( 'premium-support', EP_ROOT | EP_PAGES );
}

add_action( 'init', 'bbloomer_add_premium_support_endpoint' );


// ------------------
// 2. Add new query var

function bbloomer_premium_support_query_vars( $vars ) {
$vars[] = 'premium-support';
return $vars;
}

add_filter( 'query_vars', 'bbloomer_premium_support_query_vars', 0 );


// ------------------
// 3. Insert the new endpoint into the My Account menu

function bbloomer_add_premium_support_link_my_account( $items ) {
$items['premium-support'] = 'Premium Support';
return $items;
}

add_filter( 'woocommerce_account_menu_items', 'bbloomer_add_premium_support_link_my_account' );


// ------------------
// 4. Add content to the new endpoint

function bbloomer_premium_support_content() {
echo '<h3>Premium WooCommerce Support</h3><p>Welcome to the WooCommerce support area. As a premium customer, you can submit a ticket should you have any WooCommerce issues with your website, snippets or customization. <i>Please contact your theme/plugin developer for theme/plugin-related support.</i></p>';
echo do_shortcode( ' /* your shortcode here */ ' );
}

add_action( 'woocommerce_account_premium-support_endpoint', 'bbloomer_premium_support_content' );
// Note: add_action must follow 'woocommerce_account_{your-endpoint-slug}_endpoint' format

----------------------------------------------------------------------------

I don't know if it is LS issue or Permalink issue, but we've tried everything and still nothing works.

Any help will be appreciated.

Thanks.

Comments

  • Restart OpenLiteSpeed whenever you change permalinks settings or go for CyberPanel Ent where you get LiteSpeed Ent (full Apache compatible, so no need to restart).

    So when you change permalink settings restart OpenLiteSpeed so that it can read new htaccess file.
  • Type your comment> @CyberPanel said:
    > Restart OpenLiteSpeed whenever you change permalinks settings or go for CyberPanel Ent where you get LiteSpeed Ent (full Apache compatible, so no need to restart).
    >
    > So when you change permalink settings restart OpenLiteSpeed so that it can read new htaccess file.

    Hi,

    We've done that and still no change. However, at some point it fixed itself and we don't know how and when. It was during our nighttime.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!