CyberPanel won't install on CentOS 8 with MariaDB 10.5.x Installed — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

CyberPanel won't install on CentOS 8 with MariaDB 10.5.x Installed

Provider: Contaba

Virtualization Type: VPS

System: Centos 8

Installation option: CyberPanel

OLS or Enterprise?
OLS

Installing from official server or mirror server?
official

Install Memcached extension for PHP?
yes

Install LiteSpeed Memcached?
yes

Install Memcached?
yes

Install Redis extension for PHP?
yes

Install Redis?
yes


Problem:

I have already MariaDB 10.5.x installed on Centos 8 and get the following error when I try to install CyberPanel 2.0.3. My understanding is that this should work with MariaDB 10.5.x.

Error:
Problem: package mariadb-devel-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64 requires mariadb-connector-c-devel >= 3.0, but none of the providers can be installed
- package mariadb-connector-c-devel-3.0.7-1.el8.i686 requires libmariadb.so.3, but none of the providers can be installed
- package mariadb-connector-c-devel-3.0.7-1.el8.x86_64 requires mariadb-connector-c = 3.0.7-1.el8, but none of the providers can be installed
- package MariaDB-shared-10.5.3-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.i686
- package MariaDB-shared-10.5.3-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.x86_64
- problem with installed package MariaDB-shared-10.5.5-1.el8.x86_64
- package MariaDB-shared-10.5.4-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.i686
- package MariaDB-shared-10.5.4-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.x86_64
- conflicting requests
- package MariaDB-shared-10.5.5-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.i686
- package MariaDB-shared-10.5.5-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.x86_64
- installed package MariaDB-shared-10.5.5-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.i686
- installed package MariaDB-shared-10.5.5-1.el8.x86_64 obsoletes mariadb-connector-c provided by mariadb-connector-c-3.0.7-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

command failed, exiting...

Comments

  • edited September 28
    In the list of features it also clearly shows that it supports "Upgrade MariaDB to 10.5". However, after installing CyberPanel v2.0.3, it clearly shows that it installed MariaDB 10.3.x. If you try to upgrade MariaDB to 10.5.x after installing CyberPanel, the MariaDB also has installation issues/errors.

    I admit I may be misinterpreting something here, but what I can't understand is that if the list of features show MariaDB 10.5.x why does it install 10.3.x instead? Furthermore, why would I run into countless issues trying to upgrade MariaDB 10.5.x after installing it if the 10.5 support is claimed to be in this version. I'm presuming that would be supported in Centos 8 (not just CentOS 7).
  • edited September 28
    I concede to your point that I should NOT install MariaDB first. It now also makes sense that the feature claim only applies to Centos 7 (not 8). Then I would suggest that should be clearly stated, especially with more new Centos installs occurring with version 8, that is a bit misleading (not to mention frustrating when you're trying to figure out why 10.5 is not present).

    I appreciate your understanding and guidance. I'm relatively new to this, so I appreciate your saving me from further frustration. Will support for newer versions of MariaDB on Centos 8 likely be integrated into future releases?
  • I appreciate it! Thanks for all your efforts! For now, I can live with the present version of MariaDB until further light is shed on an upgrade path.

    Thanks for taking the time to address my concerns. My apologies for reporting a "non-bug" :)
  • > If I can confirm a complete work around it will be given here and on the FB forum and then I will discuss implementation into the installer/upgrade.

    This is great to know. Thanks.
  • > @hennaboy said:
    > I have followed my post in the other discussion and installed mariadb 10.5 on centos 8
    >
    > As stated you need to remove postfix and dovecot and disable the gf.repo
    >
    > You should note that postfix and dovecot are lower versions due to libmysqlclient.so.21 not being available. This will therefore make postfix SNI feature unavailable.
    >
    > I am therefore putting this down to custom requirement as the packages are not available and causes other features to not function.

    I compared postfix and dovecot in the CentOS repo to the gf.repo and saw the lower version in the CentOS repo, but had no idea this forfeits postfix SNI. Amazing.

    Thank you for bringing this to our attention.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!