Wordpress multisite subsites pages permalinks — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

Wordpress multisite subsites pages permalinks

Hello, I have a working wordpress multisite installation with subsites using subdomains.

Everything was working fine with pages under subsites working with the %postname%/ setting in the permalink options, but suddenly permalinks of pages inside subsites (subsite.mainsite.com/page) stopped working, only plain permalinks works.

Subdomains and http to https redirection is working fine, but subsites inner pages are not.

Any idea on what is not working here? thanks in advance for any help you can provide me.

This is my htaccess:

### Rewrite Rules Added by CyberPanel Rewrite Rule Generator

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]

### End CyberPanel Generated Rules.

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^/ - [L]
RewriteRule ^/(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^/(.*\.php)$ $1 [L]
RewriteRule . index.php [L]


And this is my vhost conf

docRoot $VH_ROOT/public_html
vhDomain $VH_NAME
vhAliases *.$VH_NAME
adminEmails [email protected]
enableGzip 1
enableIpGeo 1

errorlog $VH_ROOT/logs/$VH_NAME.error_log {
useServer 0
logLevel ERROR
rollingSize 10M
}

accesslog $VH_ROOT/logs/$VH_NAME.access_log {
useServer 0
logFormat "%h %l %u %t "%r" %>s %b "%{Referer}i" "%{User-Agent}i""
logHeaders 5
rollingSize 10M
keepDays 10
compressArchive 1
}

index {
useServer 0
indexFiles index.php, index.html
}

scripthandler {
add lsapi:site8400 php
}

phpIniOverride {
auto_prepend_file = '/home/mysite/public_html/wordfence-waf.php'
}

extprocessor yappa8400 {
type lsapi
address UDS://tmp/lshttpd/site8400.sock
maxConns 10
env LSAPI_CHILDREN=10
initTimeout 600
retryTimeout 0
persistConn 1
pcKeepAliveTimeout 1
respBuffer 0
autoStart 1
path /usr/local/lsws/lsphp74/bin/lsphp
extUser yappa8400
extGroup yappa8400
memSoftLimit 2047M
memHardLimit 2047M
procSoftLimit 400
procHardLimit 500
}

context exp:^.*(woff|woff2|jpg|jpeg|png|css|js)$ {
location $DOC_ROOT/$0
allowBrowse 1
enableExpires 1
expiresByType application/javascript=A15552000, text/css=A15552000
extraHeaders <<<END_extraHeaders
unset Cache-control
set Cache-control public, max-age=15552000
END_extraHeaders



addDefaultCharset off

rewrite {
enable 1
autoLoadHtaccess 1
}

vhssl {
keyFile /etc/letsencrypt/live/mysite.com/privkey.pem
certFile /etc/letsencrypt/live/mysite.com/fullchain.pem
certChain 1
sslProtocol 24
ciphers 98798798798798798797
enableECDHE 1
renegProtection 1
sslSessionCache 1
enableSpdy 15
enableStapling 1
ocspRespMaxAge 86400
}

Comments

  • Solved myself, for an unknow reason the rewrite option on OLS was off for the domain. Activated to read from .htaccess and everything was working again.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion