DKIM Manager not able to generate keys — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

DKIM Manager not able to generate keys

I tried to generate DKIM keys but it was not successful. The message was this:

[Errno 13] Permission denied: '/usr/local/CyberCP/lib/python3.6/site-packages/tldextract/.suffix_cache/publicsuffix.org-tlds/de84b5ca2167d4c83e38fb162f2e8738.tldextract.json.lock'

My other CyberPanel install on a different server was running fine. Can anyone point out what causes this to fail?

Comments

  • I have the same error.
  • Had the same problem, here's how I solved it.

    First off, `/usr/local/CyberCP/lib/python3.6` was not present on my system, but `python3.8` instead. So I created a symbolic link for force the path to traverse `python3.8` instead (commands issued as root, otherwise prepend `sudo `):

    ```
    $ ln -s python3.8 /usr/local/CyberCP/lib/python3.6
    ```

    Second, directory `/usr/local/CyberCP/lib/python3.6/site-packages/tldextract/.suffix_cache` and everything beyond belonged to root:root. So I changed ownership of directory and beyond to cyberpanel:cyberpanel:

    ```
    $ chown -R cyberpanel:cyberpanel /usr/local/CyberCP/lib/python3.6/site-packages/tldextract/.suffix_cache
    ```

    And then I was able to issue DKIM certificates!

    @simyseng : Can you confirm the ownership of .suffix_cache and below on your server where it ran correctly?

    @CyberPanel: please enable MarkDown in forums!
  • It's a bug. Update CyberPanel with this shell

    sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)
  • Type your comment> @simyseng said:
    > It's a bug. Update CyberPanel with this shell
    >
    > sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)
    >

    I've got the same problem and tried your solution. But unfortunately, this update is messing up my sudo rights of my main user. I already had the same problem with the update and it took a while to fix the user groups and sudo rights. So I've decided to just roll back to the last snapshot. Why is this update changing my sudo rights?
  • I've now also changed the ownership

    chown -R cyberpanel:cyberpanel /usr/local/CyberCP/lib/python3.6/site-packages/tldextract/.suffix_cache

    And everything is working fine again.
  • I've fixed it yesterday -> https://github.com/usmannasir/cyberpanel/commit/ec535d09611b4c11b22bb4ea73e826c03b61f68d?fbclid=IwAR0Zf39aPfhfOOkQCldJOmZAi154sEqsyfnPQyVZOEqiEPAlzAt2W9giI94
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!