Default user creation creates a user with wrong vhost conf — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

Default user creation creates a user with wrong vhost conf

I have installed AWS AMI cyberpanel. But facing issue in default vhost conf. When i observer vhost conf of a new user, I see this:

extprocessor xxxx4725 {
type lsapi
address UDS://tmp/lshttpd/xxxx4725.sock
maxConns 10
env LSAPI_CHILDREN=10
initTimeout 600
retryTimeout 0
persistConn 1
pcKeepAliveTimeout 1
respBuffer 0
autoStart 1
path /usr/local/lsws/lsphp70/bin/lsphp
extUser xxxx4725
extGroup xxxx4725
memSoftLimit 2047M
memHardLimit 2047M
procSoftLimit 400
procHardLimit 500
}

But when you explore files, you dont have any path as /usr/local/lsws/lsphp70/bin/lsphp. As soon as we change it to /usr/local/lsws/lsphp73/bin/lsphp or /usr/local/lsws/lsphp74/bin/lsphp, one click wordpress installations start working.

Is there any way to fix default vhost conf templates?

P.S I haven't changed anything up till now and using right out of the box AWS AMI installation.

Comments

  • it seems php70 not installed in your server but cyberpanel have the php70 enties in their database

    so try to install lsphp70 manually
    if you're using centos7 then try to install it like yum install lsphp70 and after that install necessary modules for 7.0 from cyberpanel

    also when you creating a website there is an option to select the PHP version too, so select other PHP versions other than 7.0 if you don't want php70 to be activated by default when you creating a site.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion