PHP 8.0 imagick: Anyone managed to install module lsphp80-imagick on CP 2.0.3? — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

PHP 8.0 imagick: Anyone managed to install module lsphp80-imagick on CP 2.0.3?

When I try to install PHP module lsphp80-imagick, I get this:

```
Reading package lists...
Building dependency tree...
Reading state information...
PHP Extension Installed.
```

But the module still displays as *Not-Installed*.

By contrast, installing it on PHP 7.4 does work. Here is what a normal installation log looks like:

```
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
lsphp74-imagick
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
Need to get 0 B/96.9 kB of archives.
After this operation, 495 kB of additional disk space will be used.
Selecting previously unselected package lsphp74-imagick.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 130775 files and directories currently installed.)
Preparing to unpack .../lsphp74-imagick_3.4.4-1+focal_amd64.deb ...
Unpacking lsphp74-imagick (3.4.4-1+focal) ...
Setting up lsphp74-imagick (3.4.4-1+focal) ...
PHP Extension Installed.
```

I need this to run Nextcloud 21 on PHP 8.0. I guess I'll have to run it on PHP 7.4 until this issue gets fixed.

Comments

  • I haven't figured it out so far but you can try https://freek.dev/1845-building-the-imagick-php-extension-from-master
  • We are also having an issue with this.

    Trying to enable the extension from within CP gives this:

    Last metadata expiration check: 2:50:38 ago on Mon Mar 15 23:22:00 2021.
    No match for argument: lsphp80-pecl-imagick
    PHP Extension Installed.

    But it does not install the extension.
    S-4.host - Sustainable, Secure, Speedy and Stable WP hosting built on Litespeed Ent. and Cyberpanel
  • Yeah, I'm having the same problem. Click the install button on CyberPanel, it says

    Reading package lists...
    Building dependency tree...
    Reading state information...
    PHP Extension Installed.

    But return to the previous panel and it isn't installed nor is it seen by wordpress.

    I rebooted everything. Still no luck.
  • Just wondering if anyone can confirm if this issue is solved in 2.1.1 ?
    S-4.host - Sustainable, Secure, Speedy and Stable WP hosting built on Litespeed Ent. and Cyberpanel
  • Type your comment> @S4_Hosting said:
    > Just wondering if anyone can confirm if this issue is solved in 2.1.1 ?

    I just upgraded one of my sites, and it's the same problem it does not work.
    Seems there is a way to make a build, but I think it's something that needs to be addressed, A shame I wanted to give PHP8 good testing on WP sites but seems don't pass basic check on site health.
  • submitted an issue on GitHub - https://github.com/usmannasir/cyberpanel/issues/596
    S-4.host - Sustainable, Secure, Speedy and Stable WP hosting built on Litespeed Ent. and Cyberpanel
  • Because Litespeed and OLS use lsphp, the missing packages for lsphp80 will be available when the LS and OLS teams complete the deployment. For now, there are a few more packages missing from the repo.
  • Type your comment> @chiareu said:
    > Because Litespeed and OLS use lsphp, the missing packages for lsphp80 will be available when the LS and OLS teams complete the deployment. For now, there are a few more packages missing from the repo.

    I think that is only part of the issue here though, the other part is that CP lists it as available, says it is installing it, and says it is installed. That is just confusing, if something is not available in the repo then there should not be an active option to install it.
    S-4.host - Sustainable, Secure, Speedy and Stable WP hosting built on Litespeed Ent. and Cyberpanel
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!