installation centos 7 bug — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

installation centos 7 bug

[[email protected] ~]# sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1305 100 1305 0 0 4653 0 --:--:-- --:--:-- --:--:-- 4660
Checking and installing curl and wget

~~~~~~~~~~
Github URL: github.com/usmannasir/cyberpanel
Github Content URL: raw.githubusercontent.com/usmannasir/cyberpanel
Github Branch: v2.0.3
~~~~~~~~~~

Initializing...

Valid IP detected...

Checking server...

Checking OS...

Detecting CentOS 7.X...

Checking virtualization type...

Checking root privileges...


You are runing as root...

CyberPanel Installer v2.03

1. Install CyberPanel.

2. Addons and Miscellaneous

3. Exit.


Please enter the number[1-3]: 1

CyberPanel Installer v2.03

RAM check : 44/989MB (4.45%)

Disk check : 2/20GB (15%) (Minimal 10GB free space)

1. Install CyberPanel with OpenLiteSpeed.

2. Install Cyberpanel with LiteSpeed Enterprise.

3. Exit.


Please enter the number[1-3]: 1


Install Full service for CyberPanel? This will include PowerDNS, Postfix and Pure-FTPd.

Full installation [Y/n]: y

Full installation selected...

Do you want to setup Remote MySQL? (This will skip installation of local MySQL)

(Default = No) Remote MySQL [y/N]: n

Local MySQL selected..

Press Enter key to continue with latest version or Enter specific version such as: 1.9.4 , 2.0.1 , 2.0.2 ...etc
5.7.0
set branch name to v5.7.0

Please choose to use default admin password 1234567, randomly generate one (recommended) or specify the admin password?
Choose [d]fault, [r]andom or [s]et password: [d/r/s] d

Admin password will be set to 1234567


Do you wish to install Memcached extension and backend?
Please select [Y/n]: y

Do you wish to install Redis extension and backend?
Please select [Y/n]: y

Would you like to set up a WatchDog (beta) for Web service and Database service ?
The watchdog script will be automatically started up after installation and server reboot
If you want to kill the watchdog , run watchdog kill
Please type Yes or no (with capital Y, default Yes):
y
Loaded plugins: copr, fastestmirror, priorities
Cleaning repos: base epel extras gf ius lux mariadb powerdns-auth-43 updates
Cleaning up list of fastest mirrors
Loaded plugins: copr, fastestmirror, priorities
Determining fastest mirrors
epel/x86_64/metalink | 17 kB 00:00
* base: mirror.netweaver.uk
* epel: fedora.cu.be
* extras: mirror.netweaver.uk
* updates: mirror.netweaver.uk
base | 3.6 kB 00:00
epel | 4.7 kB 00:00
extras | 2.9 kB 00:00
gf | 2.9 kB 00:00
ius | 1.3 kB 00:00
lux | 3.0 kB 00:00
mariadb | 2.9 kB 00:00
powerdns-auth-43 | 2.9 kB 00:00
updates | 2.9 kB 00:00
(1/12): base/7/x86_64/group_gz | 153 kB 00:00
(2/12): base/7/x86_64/primary_db | 6.1 MB 00:00
(3/12): epel/x86_64/group_gz | 96 kB 00:00
(4/12): extras/7/x86_64/primary_db | 230 kB 00:00
(5/12): epel/x86_64/updateinfo | 1.0 MB 00:00
(6/12): epel/x86_64/primary_db | 6.9 MB 00:00
(7/12): powerdns-auth-43/7/x86_64/primary_db | 50 kB 00:00
(8/12): lux/7/primary_db | 1.1 MB 00:00
(9/12): updates/7/x86_64/primary_db | 6.5 MB 00:00
(10/12): mariadb/primary_db | 71 kB 00:00
(11/12): ius/x86_64/primary | 113 kB 00:01
(12/12): gf/x86_64/primary_db | 54 kB 00:01
ius 527/527
10 packages excluded due to repository priority protections
No packages marked for update
Loaded plugins: copr, fastestmirror, priorities
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:7-13 will be erased
--> Processing Dependency: epel-release = 7 for package: ius-release-2-1.el7.ius.noarch
--> Running transaction check
---> Package ius-release.noarch 0:2-1.el7.ius will be erased
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Removing:
epel-release noarch 7-13 @epel 25 k
Removing for dependencies:
ius-release noarch 2-1.el7.ius @/ius-release-el7 4.5 k

Transaction Summary
================================================================================
Remove 1 Package (+1 Dependent package)

Installed size: 29 k
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Erasing : ius-release-2-1.el7.ius.noarch 1/2
Erasing : epel-release-7-13.noarch 2/2
Verifying : ius-release-2-1.el7.ius.noarch 1/2
Verifying : epel-release-7-13.noarch 2/2

Removed:
epel-release.noarch 0:7-13

Dependency Removed:
ius-release.noarch 0:2-1.el7.ius

Complete!
Loaded plugins: copr, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirror.netweaver.uk
* extras: mirror.netweaver.uk
* updates: mirror.netweaver.uk
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:7-11 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
epel-release noarch 7-11 extras 15 k

Transaction Summary
================================================================================
Install 1 Package

Total download size: 15 k
Installed size: 24 k
Downloading packages:
epel-release-7-11.noarch.rpm | 15 kB 00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : epel-release-7-11.noarch 1/1
Verifying : epel-release-7-11.noarch 1/1

Installed:
epel-release.noarch 0:7-11

Complete!
Loaded plugins: copr, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirror.netweaver.uk
* epel: fedora.cu.be
* extras: mirror.netweaver.uk
* updates: mirror.netweaver.uk
10 packages excluded due to repository priority protections
Package yum-plugin-priorities-1.1.31-54.el7_8.noarch already installed and latest version
Nothing to do
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 559 100 559 0 0 2270 0 --:--:-- --:--:-- --:--:-- 2272
Loaded plugins: copr, fastestmirror, priorities
gf-release-latest.gf.el7.noarch.rpm | 7.8 kB 00:00
Examining /var/tmp/yum-root-bi2Rwr/gf-release-latest.gf.el7.noarch.rpm: gf-release-7-10.gf.el7.noarch
/var/tmp/yum-root-bi2Rwr/gf-release-latest.gf.el7.noarch.rpm: does not update installed package.
Error: Nothing to do
Loaded plugins: copr, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirror.netweaver.uk
* epel: fedora.cu.be
* extras: mirror.netweaver.uk
* updates: mirror.netweaver.uk
mariadb | 2.9 kB 00:00
powerdns-auth-43 | 2.9 kB 00:00
10 packages excluded due to repository priority protections
Package yum-plugin-copr-1.1.31-54.el7_8.noarch already installed and latest version
Nothing to do
Loaded plugins: copr, fastestmirror, priorities
Error: [Errno 14] HTTPS Error 302 - Found
Loaded plugins: copr, fastestmirror, priorities
lux-release-7-1.noarch.rpm | 12 kB 00:00
Examining /var/tmp/yum-root-bi2Rwr/lux-release-7-1.noarch.rpm: lux-release-7-1.noarch
/var/tmp/yum-root-bi2Rwr/lux-release-7-1.noarch.rpm: does not update installed package.
Error: Nothing to do
Loaded plugins: copr, fastestmirror, priorities
ius-release-el7.rpm | 8.2 kB 00:00
Examining /var/tmp/yum-root-bi2Rwr/ius-release-el7.rpm: ius-release-2-1.el7.ius.noarch
Marking /var/tmp/yum-root-bi2Rwr/ius-release-el7.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package ius-release.noarch 0:2-1.el7.ius will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
ius-release noarch 2-1.el7.ius /ius-release-el7 4.5 k

Transaction Summary
================================================================================
Install 1 Package

Total size: 4.5 k
Installed size: 4.5 k
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : ius-release-2-1.el7.ius.noarch 1/1
Verifying : ius-release-2-1.el7.ius.noarch 1/1

Installed:
ius-release.noarch 0:2-1.el7.ius

Complete!

Installing necessary components...
Loaded plugins: copr, fastestmirror, priorities
Cleaning repos: base epel extras gf ius lux mariadb powerdns-auth-43 updates
Cleaning up list of fastest mirrors
Loaded plugins: copr, fastestmirror, priorities
Determining fastest mirrors
epel/x86_64/metalink | 17 kB 00:00
* base: mirror.netweaver.uk
* epel: fedora.cu.be
* extras: mirror.netweaver.uk
* updates: mirror.netweaver.uk
base | 3.6 kB 00:00
epel | 4.7 kB 00:00
extras | 2.9 kB 00:00
gf | 2.9 kB 00:00
ius | 1.3 kB 00:00
lux | 3.0 kB 00:00
mariadb | 2.9 kB 00:00
powerdns-auth-43 | 2.9 kB 00:00
updates | 2.9 kB 00:00
(1/12): base/7/x86_64/group_gz | 153 kB 00:00
(2/12): base/7/x86_64/primary_db | 6.1 MB 00:00
(3/12): epel/x86_64/group_gz | 96 kB 00:00
(4/12): extras/7/x86_64/primary_db | 230 kB 00:00
(5/12): epel/x86_64/updateinfo | 1.0 MB 00:00
(6/12): epel/x86_64/primary_db | 6.9 MB 00:00
(7/12): ius/x86_64/primary | 113 kB 00:00
(8/12): powerdns-auth-43/7/x86_64/primary_db | 50 kB 00:00
(9/12): updates/7/x86_64/primary_db | 6.5 MB 00:00
(10/12): lux/7/primary_db | 1.1 MB 00:00
(11/12): mariadb/primary_db | 71 kB 00:00
(12/12): gf/x86_64/primary_db | 54 kB 00:01
ius 527/527
10 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:7-11 will be updated
---> Package epel-release.noarch 0:7-13 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Updating:
epel-release noarch 7-13 epel 15 k

Transaction Summary
================================================================================
Upgrade 1 Package

Total download size: 15 k
Downloading packages:
epel/x86_64/prestodelta | 324 B 00:00
epel-release-7-13.noarch.rpm | 15 kB 00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Updating : epel-release-7-13.noarch 1/2
Cleanup : epel-release-7-11.noarch 2/2
Verifying : epel-release-7-13.noarch 1/2
Verifying : epel-release-7-11.noarch 2/2

Updated:
epel-release.noarch 0:7-13

Complete!
Loaded plugins: copr, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirror.netweaver.uk
* epel: fedora.cu.be
* extras: mirror.netweaver.uk
* updates: mirror.netweaver.uk
10 packages excluded due to repository priority protections
Package wget-1.14-18.el7_6.1.x86_64 already installed and latest version
Package strace-4.24-6.el7.x86_64 already installed and latest version
Package net-tools-2.0-0.25.20131004git.el7.x86_64 already installed and latest version
Package curl-7.29.0-59.el7_9.1.x86_64 already installed and latest version
Package which-2.20-7.el7.x86_64 already installed and latest version
Package bc-1.06.95-13.el7.x86_64 already installed and latest version
Package 1:telnet-0.17-66.el7.x86_64 already installed and latest version
Package htop-2.2.0-3.el7.x86_64 already installed and latest version
Package libevent-devel-2.0.21-4.el7.x86_64 already installed and latest version
Package gcc-4.8.5-44.el7.x86_64 already installed and latest version
Package libattr-devel-2.4.46-13.el7.x86_64 already installed and latest version
Package xz-devel-5.2.2-1.el7.x86_64 already installed and latest version
Package gpgme-devel-1.3.2-5.el7.x86_64 already installed and latest version
Package libcurl-devel-7.29.0-59.el7_9.1.x86_64 already installed and latest version
Package git-2.17.0-1.el7.lux.x86_64 already installed and latest version
Package socat-1.7.3.2-5.el7.lux.x86_64 already installed and latest version
Package 1:openssl-devel-1.0.2k-21.el7_9.x86_64 already installed and latest version
Package MariaDB-shared-10.5.9-1.el7.centos.x86_64 already installed and latest version
Package 1:mariadb-devel-5.5.68-1.el7.x86_64 is obsoleted by MariaDB-devel-10.5.9-1.el7.centos.x86_64 which is already installed
Package yum-utils-1.1.31-54.el7_8.noarch already installed and latest version
Package python36-3.6.8-2.el7.ius.x86_64 is obsoleted by python3-3.6.8-18.el7.x86_64 which is already installed
Package python36-pip-9.0.1-2.el7.ius.noarch is obsoleted by python3-pip-9.0.3-8.el7.noarch which is already installed
Package python36-devel-3.6.8-2.el7.ius.x86_64 is obsoleted by python3-devel-3.6.8-18.el7.x86_64 which is already installed
Nothing to do
Loaded plugins: copr, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirror.netweaver.uk
* epel: fedora.cu.be
* extras: mirror.netweaver.uk
* updates: mirror.netweaver.uk
10 packages excluded due to repository priority protections
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
ln: failed to create symbolic link '/usr/bin/pip': File exists
WARNING: Running pip install with root privileges is generally not a good idea. Try `pip install --user` instead.
Requirement already satisfied: virtualenv==16.7.9 in /usr/local/lib/python3.6/site-packages
--2021-04-04 11:16:49-- https://raw.githubusercontent.com/usmannasir/cyberpanel/v5.7.0/requirments.txt
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 185.199.111.133, 185.199.108.133, 185.199.110.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|185.199.111.133|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2021-04-04 11:16:49 ERROR 404: Not Found.

Already using interpreter /usr/bin/python3
Using base prefix '/usr'
No LICENSE.txt / LICENSE found in source
New python executable in /usr/local/CyberPanel/bin/python3
Not overwriting existing python script /usr/local/CyberPanel/bin/python (you must use /usr/local/CyberPanel/bin/python3)
Installing setuptools, pip, wheel...
done.
fatal: destination path 'cyberpanel' already exists and is not an empty directory.
error: pathspec 'v5.7.0' did not match any file(s) known to git.

command failed, exiting...
[[email protected] ~]#
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!