Getting really high (initial server response time) TTFB score — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Getting really high (initial server response time) TTFB score

Hello everyone, I am migrating a website of mine from aws to Linode (India datacenter) But i am not getting the speed. I ran multiple tests on gtmetrix but got similar results which convince the fact that there is some issue with the server.
The concerning issue is the initial server response time (TTFB) is almost over 1 second
1: I have installed cyberpanel on 1 CPU,1 GB ram Linode vps
2: Installed WordPress and then migrated my already optimized WordPress using a migration plugin
3: The website is using Litespeed caching plugin. So its serving everything cached.
4: I'm using statically CDN to serve images and js files.
5: All images are optimized and the page size is around 300kb

Comments

  • Initial TTFB is always related to server and nothing to do with CyberPanel or LiteSpeed.
  • If you want to host only 1 website I suggest you switch from OLS to LSWS as it is more optimized and uses 1 worker by default.

    Moreover; GTMetrix uses Canadian servers by default, routing to India might not be ideal. You'll get more acurate results by using the chrome lighthouse test, as that would test the website and server speed from your own network and not any 3rd party service location.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!