404 error page after installing cyberpanel (wordpress) — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

404 error page after installing cyberpanel (wordpress)

hey there i am using vps on digitalocean and i installed cyberpanel and then wordpress using create website and i followed this tutorial to migrate my website https://blog.cyberpanel.net/2018/04/30/wp-migration-from-any-control-panel-to-cyberpanel/
and now everything is setup but the problem is when i open my digitalocean ip to check if wordpresss is installed correctly so i can move my public domain dns here so when i open my ip i am getting 404
Not Found
The resource requested could not be found on this server!


Proudly powered by LiteSpeed Web Server
Please be advised that LiteSpeed Technologies Inc. is not a web hosting company and, as such, has no control over content found on this site.

i don't know whats wrong i even added that rewrite rule which was in the tutorial kindly assist me solving its urgent :)

Comments

  • Just restart OpenLiteSpeed so rewrite rules can be followed.
  • > @usmannasir said:
    > Just restart OpenLiteSpeed so rewrite rules can be followed.

    Already did that and still its showing that error page
  • Paste your rewrite rules below.
  • You have to go to your site in the CyberPanel click on the rewrite rules and check it if the same that wordpress need like this:

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    and then click on the button save rewrite rules and test your site again.

  • Correct, these are effective rules from CyberPanel version v.1.70 and above.
  • thanks for replying really appreciate it, i added your the rules mentioned above and yet no luck... but i figured something out if i create a website through cyberpanel and enter a domain name for example mywebsite.com then change settings in etc/hosts in windows to make it think that mywebsite.com is actually there then it works fine but still on my ip there is a 404 error and one more thing after i added database in phpmyadmin since then cyberpanel is loading very slowly.
  • Correct me if I am wrong, through IP you mean with preview feature inside CyberPanel you get 404?

    Plus if you get the correct site with modifying your /etc/hosts files then you are on right path and everything is working correctly.

    Because with preview features it is not able to identify the correct path for some files and you get 404.
  • Correct me if I am wrong, through IP you mean with preview feature inside CyberPanel you get 404?

    Plus if you get the correct site with modifying your /etc/hosts files then you are on right path and everything is working correctly.

    Because with preview features it is not able to identify the correct path for some files and you get 404.

    don't know about the preview feature but yeah i got my website working through etc/hosts
    the 404 error appears when i put my vps ip in browser.
  • izaan said:

    Correct me if I am wrong, through IP you mean with preview feature inside CyberPanel you get 404?

    Plus if you get the correct site with modifying your /etc/hosts files then you are on right path and everything is working correctly.

    Because with preview features it is not able to identify the correct path for some files and you get 404.

    don't know about the preview feature but yeah i got my website working through etc/hosts
    the 404 error appears when i put my vps ip in browser.
    Your site is already successfully transferred.
  • edited March 2019
    I am having the same exact issue, 404 in preview mode after transferring files to CyberPanel. Can you help me solve this issue?
  • Finally found the solution. Wordpress plugin Litespeed cache. 404 is reported because the Wordpress site that you try to import does not have this plugin.

    I worked out by adding a dummy website abc.com and installing Wordpress through cyber panel. Once installation is done, you co go to file manager - <<public_html/wp-content/plugin/ >> and compress the directory litespeed-cache. Download the plugin content and upload the compressed file in the same directory of website where 404 is being reported. - Uncompress the plugin and Voila your website is working.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!