Wordpress: Installation failed. Error message: [404] - Page 2 — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Wordpress: Installation failed. Error message: [404]

2»

Comments

  • I also tried to install WordPress manually, but now this time getting WordPress troubleshooting error. @usmannasir please provide any solution. I'm stuck here,
  • Finally, after many efforts I deleted my server and deploy it again, and this time it's working fine. I didn't learn anything from it as I still don't know why this issue come to my server. BTW CyberPanel is an amazing free resource but with a lack of support. Deploy the server again is not the solution.
  • Hi!
    I had the same problem but I already had a website working and I went to install the second one and it happened. I was afraid to run the command install php_mysql and that would cause problems on the site already working. I found that when installing the site it does not create the database. So I created it manually and edited the wp- file
    config of the new site with the data but the installation was default, without the LS Cache.
    If I ran the install command, would it harm the site running?
    Thanks a lot!
  • I had this problem also but it was related to my mysql config file "/etc/my.cnf"

    I had to remove 2 lines:
    bind-address=xx.xxx.xxx.xxx
    skip-name-resolve

    restarted mysql and issue was resolved in centos 7
  • The command "sudo apt-get install php-mysql" solved it in my case.
    Ubuntu 20.04 and PHP 7.4
  • Hi!
    I've got still issue on CentOS 7.9
    Trying to install WP and getting "Installation failed. Error message: [Errno 13] Permission denied:"

    Run command touch /usr/local/CyberCP/debug - doesn't work for me.
    But journalctl -f | grep lscpd shows me

    root : TTY=unknown ; PWD=/tmp/lscpd ; USER=root ; COMMAND=/bin/cat /home/cyberpanel/6370
    root : TTY=unknown ; PWD=/tmp/lscpd ; USER=root ; COMMAND=/bin/chown -R cyberpanel:cyberpanel /home/cyberpanel
    root : TTY=unknown ; PWD=/tmp/lscpd ; USER=root ; COMMAND=/bin/wp --info
    root : TTY=unknown ; PWD=/tmp/lscpd ; USER=root ; COMMAND=/bin/chmod 755 /home/timkod.ru/public_html/glamping
    root : TTY=unknown ; PWD=/tmp/lscpd ; USER=root ; COMMAND=/bin/cat /home/cyberpanel/6756


    Please help me!
  • Hi,
    Fixed it this 404 error with this command on ubuntu:

    sudo apt-get install php-mysql

    ***** [Worked for me as well ] *****

    Thanks! 23.09.21
  • Hello, a complete noob here :smile:
    I have no experience dealing with this type of issues, any way i wanted to start blogging on wordpress, i did some research and found out that the hosting server is important; i went in and baught a server on contabo, watched a few videos, installed Ubuntu on my new server, i felt like Einstein lol, eveything working fine, watched another video on how to install wordpress, followed every step and yes it worked like a charm, wordpress was installed successfully, after that i logged in to my wp-admin dashboard to fix some stuff and actually start my first blog, i said why not buy a theme so that my website looks cooler, i did that and this is when the problems started : i baught the theme but when i wanted to install it ;i got an error stating that the file size is too big, after some research i found out that i'm only able to upload files up to 2M 'in size' ,I contacted the contabo support and they said it's up to me because i baught a self managed server!!!!, after a few attempts they told me to modifi my ini.files !!!!! that was like asking me to produce a 'bomb' i got scared and i started sweating and looking at every video, every forum 'like i'm doing now'....nothing, then i watched a video stating that instaling wordpress on Cyberpanel is easier and suggested to reinstal the VPS server, i did exactly that......started all over....after setting up the VPS with ubuntu 'again' i went on and installed Cyberpanel, it worked ,i went to my dashboard and followed the steps on how to set up wordpress, it did not work every time i try i get the 404 error popup, i said i have a brilliant idea : i'll buy a new domain name and start all over again hhhh wich i did, and guess what ?
    it did not work either, now i have spent every dollar on my credit card that i was saving in order to have my own server and website and start a blog :neutral: .
    i realised that when i try to applicate the ssl it works but when i reload or go to manage the website in another tab to start installing wordpressn, it shows that it's not SSl"ed and that i should re-do it again !!!
    i'm confussed and i feel stupid and that i wasted my money for nothing.
    now i can not get back to my first wordpress because it says can't login to it an i can not start a new one because of this 404 error?
    And with technical knowledge, i'm stuck here.
  • Type your comment> @Zahid said:
    > The command "sudo apt-get install php-mysql" solved it in my case.
    > Ubuntu 20.04 and PHP 7.4

    Iam also faced same issue on Digital Ocean server, I have chosen market place to install the panel. One my three attempt the same issue was faced. So i deleted the server and installed an fresh copy using the same market place. On the frst shh login it asked for upgrade it was done, second i updated the packages and then used this comment " sudo apt-get install php-mysql " and rebooted the server. everything work fine with our any issue.
  • For me didnt worked ... i am on AWS i tried to follow both solutions... For me it sounds really annoing and a bit stupid to dont do tests of functionalities before launching updates ... This thing with personal compiled php versions that dont allow us to install wordpress it`s denotes alot of unprofessionalism... If i were a programmer and i had compiled php to suit my needs, then for sure i would check if all the apps will work with it ... in all platforms , and if not working, i would try to also compile the apps to suit my needs too...
  • For mine, I found out the website hit the limit of the number of databases for the package so the database was not created whenever WordPress tried to install.

    I increased the number of databases allowed for the package and it worked.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!