DNS could not point to special domain — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

DNS could not point to special domain

Provider
vultur

Virtualization Type
KVM

System
CentOS 7、CentOS 8、Ubuntu 18.04

OLS or Enterprise?
OLS

Installing from official server or mirror server?
official

Install Memcached extension for PHP?
yes

Install LiteSpeed Memcached?
yes

Install Memcached?
yes

Install Redis extension for PHP?
yes

Install Redis?
yes


Hi there, I just found a bug.(Bug report)
If my domain is ".co"(not .com)
Even though I could install CyberPanel and DNS direct to my VPS address.
And there is no response with my domain address.(Means DNS server can't find "mydomain.co")
If my domain is ".com" or ".tw"
There is no problems happen.

Comments

  • No issue, check your DNS configurations. Works like charm

    dig cyberpanel.co @159.65.219.60

    ; <<>> DiG 9.16.1-Ubuntu <<>> cyberpanel.co @159.65.219.60
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14196
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    ;; WARNING: recursion requested but not available

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1232
    ;; QUESTION SECTION:
    ;cyberpanel.co. IN A

    ;; ANSWER SECTION:
    cyberpanel.co. 3600 IN A 159.65.219.60

    ;; Query time: 240 msec
    ;; SERVER: 159.65.219.60#53(159.65.219.60)
    ;; WHEN: Fri Apr 30 18:07:04 PKT 2021
    ;; MSG SIZE rcvd: 58
  • That's weird,
    I did set the cloudflare to VPS's IP
    Others done well, but just only .co not worked.
  • OK, I found where the problem is.
    It seems I did some mistakes, and it's working now.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion